查看Eclipse版本号及各个版本区别和对应JDK

jdk最新版历史版本下载
http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.oracle.com/technetwork/java/javase/archive-139210.html

JDK在1.8之后会自动在path前添加JRE的环境变量
eclipse优先读取注册表的环境变量

eclipse最新版和历史版本下载
https://www.eclipse.org/downloads/eclipse-packages/
https://wiki.eclipse.org/Older_Versions_Of_Eclipse
http://www.eclipse.org/downloads/packages/all
版本历史
https://wiki.eclipse.org/Simultaneous_Release
indigo到Oxygen(3.7-4.7)的历史版本的eclipse下载
http://mirrors.ustc.edu.cn/eclipse/technology/epp/downloads/release/

3.2更早期的版本一般用的是eclipse-SDK,又称为Eclipse classic/Eclipse Standard(Eclipse经典版、Eclipse标准版),但是到3.2-4.2叫经典版,4.2之后叫标准版,实际上都是一个东西,eclipse-SDK是最精简的版本,功能上等于eclipse java版。
eclipse-SDK与eclipse java版的相同点和不同点
通过对比4.4.2版本发现
eclipse-SDK多了很多api、doc、源码、帮助文档的插件,所以看上去体积比java版的要大
java版比SDK多了eclipse的mylyn、wb、wst、m2e、logback、aether、egit、epp、recommender、xsd插件、google的gson、guava、inject插件、apache的compress、httpclient、io、lang、lang3、math、pool、solr、ws、xerces、xml插件
相同点是,都可以建java项目,进行java开发。

参见 3.0版本eclipse-SDK-3.0.1-win32.zip
http://blog.csdn.net/javamxj/article/details/131952
eclipse-SDK项目还在
http://archive.eclipse.org/eclipse/downloads/

在Neon版本之前,主版本在6月发布,每个版本都有两个SR版,这两个SR版分别在9月和2月发布。

版本代号 平台版本 主要版本发行日期 SR1发行日期 SR2发行日期 需要的JDK最低版本
Callisto 3.2 2006年6月26日 N/A N/A JDK1.4
Europa 3.3 2007年6月27日 2007年9月28日 2008年2月29日 JDK1.5
Ganymede 3.4 2008年6月25日 2008年9月24日 2009年2月25日 JDK1.5
Galileo 3.5 2009年6月24日 2009年9月25日 2010年2月26日 JDK1.5
Helios 3.6 2010年6月23日 2010年9月24日 2011年2月25日 JDK1.5
Indigo 3.7 2011年6月22日 2011年9月23日 2012年2月24日 JDK1.5
Juno 3.8及4.2 2012年6月27日 2012年9月28日 2013年3月1日 JDK1.5
Kepler 4.3 2013年6月26日 2013年9月27日 2014年2月28日 JDK1.6
Luna 4.4 2014年6月25日 2014年9月25日 2015年2月27日 JDK1.6
Mars 4.5 2015年6月24日 2015年9月22日 2016年2月24日 JDK1.7
Neon版本之后,每个主版本一般在6月发布,后续更新版在九月(* 1),十二月(* 2),和3月(* 3)发布。

版本代号 平台版本 主要版本发行日期 .1发行日期 .2发行日期 .3发行日期 需要的JDK版本
Neon 4.6 2016年6月22日 2016年9月28日 2016年12月21日 2017年3月23日 JDK1.8
Oxygen 4.7 2017年6月28日 2017年9月27日 2017年12月20日 2018年3月21日 JDK1.8
Photon 4.8 2018年6月27日 2018年9月 2018年12月 2019年3月

以上为软件安装实测,但在eclipse官网上找到这么一篇:http://wiki.eclipse.org/Eclipse/Installation
文中提到4.4Luna需要JDK7,但实测结果显示最低可以用JDK6

update2017-09-22:eclipse3.x版本及以前,大多数开发是基于IBM定制的eclipse版本进行开发

Eclipse各个版本选择标准

打开Eclipse下载地址(http://www.eclipse.org/downloads/),可以看到有好多版本的Eclipse可供下载,初学者往往是一头雾水,不知道下载哪一个版本。

经常用到的是前五个版本:
Eclipse IDE for Java EE Developers:是为J2EE开发的版本;
Eclipse Classic:是Eclipse的经典版本,没有安装任何插件,纯净版,需要什么插件可以自己安装,Java初学者建议使用该版本;
Eclipse IDE for Java Developers:适用于Java开发;
Eclipse IDE for C/C++ Developers:适用于C/C++开发;
Eclipse for Mobile Developers:适用于Java手机开发
Eclipse for RCP/Plug-in Developers:用于RCP和插件开发

那么它们之间到底有什么区别呢,最大的区别就是标题和解压包大小不同。下载解压后就会发现,不同的Eclipse版本之间就是plugins/features目录下的文件不同而已。

一个标准的Eclipse的,给它添加一些JEE开发需要的plugins,比如WTP,WST等等,它摇身一变就变成”Eclipse IDE for Java EE“了。其他的也一样。作为一个熟练的Eclipse使用者,选择哪一个都可以,需要的plugin可以从Eclipse官网轻松获取。

阅读更多
文章标签: java 环境 Eclipse
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭