POJ-2192 Zipper

POJ-2192 Zipper

题目

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:
Data set n: yes
if the third string can be formed from the first two, or
Data set n: no
if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no


题解

首先明确几点:

  • 串C的长度等于串A+串B

  • 串C中每个字符要么来自串A要么来自于串B

于是我们可以做出以下推导:

  • StrC==NULL —> A==NULL && B===NULL
  • StrC+C[1] —> Len(StrC)+1 —> Len(StrA)+1 || Len(StrB)+1
  • 因为C中的每个字符都是来自于A或者B—> C[1]==A[1] || C[1]==B[1]

因为长度相等,所以 C[i] 不是来自于 A[j] 就是来自于 B[ij] ,所以我们只需表示 A[j] 即可

于是DP递推式表示如下:

  • DP[i][j] : i ,StrC的下标, j :StrA的下标
  • DP[All][All]=0,DP[0][0]=1
  • StrC[i+1]==StrA[i+1] –> DP[i+1][j+1]=1
  • StrC[i+1]==StrB[i+1j] —> DP[i+1][j]=1
  • DP[LenC][LenA]==1 –> Yes

代码

/*********************************
Author: Toudsour
Created Time: 五  8/14 19:17:24 2015
File Name:D.cpp
*********************************/
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char StrA[210];
char StrB[210];
char StrC[410];
int DP[410][210];
int main()
{
    int T;
    scanf("%d",&T);
    for(int Case=1;Case<=T;Case++)
    {
        int LenA;
        int LenB;
        int LenC;
        scanf("%s",StrA+1);
        scanf("%s",StrB+1);
        scanf("%s",StrC+1); 
        LenA=strlen(StrA+1);
        LenB=strlen(StrB+1);
        LenC=strlen(StrC+1);
        memset(DP,0,sizeof(DP));
        DP[0][0]=1;
        for(int i=0;i<=LenC;i++)
        {
            for(int j=0;j<=LenA;j++)
                if(DP[i][j]==1)
                {
                    //cout<<StrT[i+1]<<" "<<StrO[j+1]<<" "<<StrD[i+1-j]<<endl;
                    if(StrC[i+1]==StrA[j+1])
                        DP[i+1][j+1]=1;
                    if(StrC[i+1]==StrB[i+1-j]&&(i+1-j)<=LenD)
                        DP[i+1][j]=1;
                }
        }
        if(DP[LenC][LenA])
            printf("Data set %d: yes\n",Case);
        else
            printf("Data set %d: no\n",Case);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值