Palindrome POJ-1159

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd
Sample Output
2

题意: 给定一个字符串,向字符串中插入元素,使其构成回文字符串,求插入的最少元素个数。

思路: 求字符串和其倒序组成的字符串的最长公共子序列,用字符串长度减去最长公共子序列,得到的就是不同的元素,只需插入这些元素即可构成回文字符串。

注意: 由于数据较大,所以可能会内存超限,需要用到滚动数组的知识,即重复利用空间。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
char a[6000],b[6000];
int dp[2][6000];
int main()
{
	int n;scanf("%d",&n);
		memset(dp,0,sizeof(dp));
		int i,j;
		int p=0;
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%s",a);
		for(i=n-1;i>=0;i--)
		b[p++]=a[i];
		int k=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)//当i==0时能推出第一行,当i==1时能退出第二行,当i==2时能推出第三行,此时第0行已经没有用了,可以把第三行放在第0行的位置,重复利用空间。
			{
				if(a[i]==b[j])
				dp[(i+1)%2][j+1]=dp[i%2][j]+1;
				else
				dp[(i+1)%2][j+1]=max(dp[i%2][j+1],dp[(i+1)%2][j]);
			}
		}
		printf("%d\n",n-dp[n%2][p]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值