Palindrome POJ - 1159

问题:

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

大意:

就是给你一串字符,问你最少再插入多少个字符,使之变成回文字符串。

思路:

1:只需要求出这个字符串和它倒序排列的字符串所对应的最长公共子序列的个数,然后再用总长度减去公共序列的长度就是了。

2:因为数据范围比较大,如果直接dp可能会超内存,所以可以采用滚动数组去节约内存(  一般我们dp数组都会去存储所有状态,滚动数组就是相当于用后面的状态把前面已经不需要的状态覆盖掉  )。

代码:

#define N 5010
#include<queue>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,dp[2][N];
char k[N],s[N];
int main()
{
    while(~scanf("%d",&n))
    {
        scanf("%s",k);
        for(int i=0; i<n; i++)
            s[n-i-1]=k[i];
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
        {
            //在这里我们只需要i+1和i,前面的状态已经不需要了,就可以采用%2的形式去覆盖掉
            if(k[i]==s[j])
                dp[(i+1)%2][j+1]=dp[i%2][j]+1;
            else
                dp[(i+1)%2][j+1]=max(dp[(i+1)%2][j],dp[i%2][j+1]);
        }
        printf("%d\n",n-dp[n%2][n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值