1003 of search

A strange lift

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 169   Accepted Submission(s) : 39
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 

Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5<br>3 3 1 2 5<br>0
 

Sample Output
  
  
3
 
题目要求:告诉你每层楼层可以移动的层数,由你决定是是上还是下这些层数,最后判断是否能达到指定的楼层。
题目思路:简单的dfs,需要一个标记是否访问的数组和计数dfs的次数,出口是越界或是已访问,若到达指定楼层则输出深度,并用flag标记,若flag没有标记则输出-1.
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<iomanip>
using namespace std;
int n,m,s;

struct pao
{
    int l;
    int count;
};

int main()
{ queue<pao> d;
int a[10000];
int ss[10000];
    while(cin>>n&&n!=0)
    {
        memset(ss,0,sizeof(ss));
        cin>>m>>s;

        int i;
        for(i=1;i<=n;i++)
        {
            cin>>a[i];ss[i]=0;
        }
     pao kk;
     kk.l=m;
     ss[kk.l]=1;
     kk.count=0;
      d.push(kk);
      pao k2,k3,k4;
      int e=0;
    while(!d.empty())
    {
        k2=d.front();
        d.pop();
        if(k2.l==s)
        {
               e=1;
             break;
        }
            k3.l=k2.l+a[k2.l];

             k4.l=k2.l-a[k2.l];

             if(k3.l>=1&&k3.l<=n&&ss[k3.l]==0)
            {   k3.count=k2.count+1;
                d.push(k3);ss[k3.l]=1;
            }
             if(k4.l>=1&&k4.l<=n&&ss[k4.l]==0)
            {k4.count=k2.count+1;
                d.push(k4);ss[k4.l]=1;
            }
    }
    while(!d.empty())
      {
          d.pop();
      }

     int paopaopao;
      paopaopao= k2.count;
      if(e)
      cout<<paopaopao<<endl;
      else
      cout<<"-1"<<endl;

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值