1017 of dp

Problem Q

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 75   Accepted Submission(s) : 30
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg> </center><br>
 

Input
The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 题目要求:teddy想要收集骨头,但是背包的体积有限,每个骨头都有体积和价值,要求取得最大的价值。
解题思路:简单的01背包问题,只需按照模板上来写即可。
解题代码:
#include<iostream>
#include<cstdio>
using namespace std;
int t,n,v,w[1001],c[1001];
int max(int a,int b)
{
return a>b?a:b;
}
int dp()
{
   int f[1001],i,j;
   for(i=0;i<=v;i++)
   f[i]=0;
   for(i=1;i<=n;i++)
     for(j=v;j>=c[i];j--)
    {  f[j]=max(f[j],f[j-c[i]]+w[i]);}
   return f[v];
}
int main()
{
   cin>>t;int i;
   while(t--)
   {
      cin>>n>>v;
      for(i=1;i<=n;i++)cin>>w[i];
      for(i=1;i<=n;i++) cin>>c[i];
      cout<<dp()<<endl;
   }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值