1002 of dp

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 87   Accepted Submission(s) : 35
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 题目要求:在两组字符串中找到最大公共子列求出其长度
 解题思路:比较经典的lcs算法,其状态转移方程为
  d[i,j]=0;(if(i==0||j==0)
  d[i,j]=c[i-1,j-1]+1(if(xi=yj)
   d[i,j]=max(d[i-1,j]),d[i,j-1]);(if(xi!=yj)
   在i=0或j=0时,很明显不可能有公共自序列,所以为0.在其他位置,若两个字符相同则可以加1后移一位,若不同则比较的x数列和y数列后移一位的较大值。最终将二维数组d[m][n]填满后输出d[m][n]即可。
#include<iostream>
#include<string.h>
#include<cstdio>
using namespace std;
int min(int a,int b)
{
    if(a>b)return b;
          return a;
}
int main()
{
    string a,b;
    while(cin>>a>>b)
    {
        int m,n;
        int i,j;
        m=a.size();n=b.size();
        int c[1000][1000];
       memset(c,0,sizeof(c));
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
        {
             if(a[i]==b[j])c[i+1][j+1]=c[i][j]+1;
             else if (c[i][j+1]>=c[i+1][j])c[i+1][j+1]=c[i][j+1];
             else {c[i+1][j+1]=c[i+1][j];}

        }cout<<c[m][n]<<endl;

    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值