1021 of dp

Problem U

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 3
Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. <br>Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.<br>
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. <br><br>The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.<br>
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. <br><br>Output a blank line after each test case.<br>
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 
题目要求:给你价值为1 2 3 4 5 6的各个物品,要求是否能够平均分为2份。可以的话输出can be divided,否者输出can’t  be divided。以全部为0的行为结束行。
解题思路:和前面1019题的类型完全一样,只是那个需要手动输入,而这个价值已经给定,只需输入数目,若总价值为奇数则一定不能平分,若为偶数则取其一半为背包容积,若经过多重背包后d[v]==v,则能够平分,否者不能平分。
解题代码:
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
int a[100005];
int b[100005];
int dp[100005];
int n,m;
void o1big(int vol,int val)
{
    int j;
    for(j=m;j>=vol;j--)
    {
        dp[j]=max(dp[j],dp[j-vol]+val);
    }
}
void compbig(int vol,int val)
{
    int j;
    for(j=vol;j<=m;j++)
    {
        dp[j]=max(dp[j],dp[j-vol]+val);
    }
}
void mult(int vol,int val,int ans)
{
    if(vol*ans>=m)    //等同于物品的数量无限~用完全背包。
    {
        compbig(vol,val);
        return ;
    }
    else
    {
        int k=1;
        while(k<=ans)
        {
            o1big(k*vol,k*val);
            ans=ans-k;
            k=2*k;
        }
        o1big(ans*vol,ans*val);
    }
}
int main()
{
    //freopen("r.txt","r",stdin);
    int i,k=1,j;
    a[1]=1,a[2]=2,a[3]=3,a[4]=4,a[5]=5,a[6]=6;
    while(cin>>b[1]>>b[2]>>b[3]>>b[4]>>b[5]>>b[6])  //ans!
    {
        if(b[1]+b[2]+b[3]+b[4]+b[5]+b[6]==0) break;
        memset(dp,0,sizeof(dp));
        int sum=0;
        for(i=1;i<=6;i++)
        {
            sum+=a[i]*b[i];
        }
        if(sum%2!=0)
        {
            cout<<"Collection #"<<k++<<":"<<endl;
            cout<<"Can't be divided."<<endl<<endl;
            continue;
        }
        m=sum/2;
        for(i=1;i<=6;i++)
        {
            mult(a[i],a[i],b[i]);
        }
        if(dp[m]==m)
        {
            cout<<"Collection #"<<k++<<":"<<endl;
            cout<<"Can be divided."<<endl;
        }
        else
        {
            cout<<"Collection #"<<k++<<":"<<endl;
            cout<<"Can't be divided."<<endl;
        }
        cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值