POJ 1724 Roads(深搜之寻路问题)

Description

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

N个城市,编号1到N。城市间有R条单向道路。
每条道路连接两个城市,有长度和过路费两个属性。
Bob只有K块钱,他想从城市1走到城市N。问最短共需要走多长的路。如果到不了N,输出-1。

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

分析

从第一个城市开始深搜,找到所有走法。
优化点:
1. 记录一最优路径长度L,如果搜索过程中路径长度大于L,那么就可放弃此点之后的查找。
2. minL[i][j]表示走到城市i且花费为j的情况下的最短路径长度,后续搜索中走到i时花费也是j时如果积累长度超过minL[i][j]则放弃搜索。

实现

#include <iostream>
#include <cstring>
#include <vector>
using namespace std;
//数定义大点是为防止临界条件数组越界
#define NN 110
#define RR 10010
//K:花费 N:城市数 R:路径数
int K, N, R;

struct Road
{
    //d:终点 l:长度 t:过路费
    int d, l, t;
};

vector<vector<Road>> cityMap(NN); //与i城市相邻的路
const int initValue = 1 << 30;
int minLen = initValue;
int totalLen = 0;
int totalCost = 0;
int visited[NN];
int minL[NN][RR]; //1到i城市花费为j的最短路径长度

void dfs(int s)
{
    //已走到终点则此次搜索完成
    if (s == N) {
        minLen = minLen > totalLen ? totalLen : minLen;
        return;
    }
    for (int i = 0; i < cityMap[s].size(); i++) {
        int d = cityMap[s][i].d;
        //跳过已搜索过的城市
        if (visited[d]) {
            continue;
        }
        int cost = cityMap[s][i].t + totalCost;
        int len = cityMap[s][i].l + totalLen;
        if (cost > K || len >= minLen || len >= minL[d][cost]) {
            continue;
        }

        totalLen = len;
        totalCost = cost;
        minL[d][cost] = len;
        visited[d] = 1;
        dfs(d);
        //路径搜索完成恢复状态
        totalLen -= cityMap[s][i].l;
        totalCost -= cityMap[s][i].t;
        visited[d] = 0;
    }
}

int main()
{
//  freopen("in.txt", "r", stdin);
    cin >> K >> N >> R;
    for (int i = 0; i < R; i++) {
        int source;
        Road r;
        cin >> source >> r.d >> r.l >> r.t;
        if (source != r.d) {
            cityMap[source].push_back(r);
        }
    }

//  //不知为何此句不能起作用
//  memset(minL, initValue, sizeof(minL[0][0]) * NN * RR);
    for (int i = 0; i < NN; ++i) {
        for (int j = 0; j < RR; ++j) {
            minL[i][j] = initValue;
        }
    }
    memset(visited, 0, sizeof(visited));
    //从城市1作为起点开始搜,所以此点已访问过
    visited[1] = 1;

    dfs(1);
    if (minLen < initValue) {
        cout << minLen << endl;
    }
    else {
        cout << "-1" << endl;
    }
    return 0;
}
  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值