OJ 7218 献给阿尔吉侬的花束__广搜

描述

阿尔吉侬是一只聪明又慵懒的小白鼠,它最擅长的就是走各种各样的迷宫。今天它要挑战一个非常大的迷宫,研究员们为了鼓励阿尔吉侬尽快到达终点,就在终点放了一块阿尔吉侬最喜欢的奶酪。现在研究员们想知道,如果阿尔吉侬足够聪明,它最少需要多少时间就能吃到奶酪。

迷宫用一个R×C的字符矩阵来表示。字符S表示阿尔吉侬所在的位置,字符E表示奶酪所在的位置,字符#表示墙壁,字符.表示可以通行。阿尔吉侬在1个单位时间内可以从当前的位置走到它上下左右四个方向上的任意一个位置,但不能走出地图边界。

输入

第一行是一个正整数T(1 <= T <= 10),表示一共有T组数据。
每一组数据的第一行包含了两个用空格分开的正整数R和C(2 <= R, C <= 200),表示地图是一个R×C的矩阵。
接下来的R行描述了地图的具体内容,每一行包含了C个字符。字符含义如题目描述中所述。保证有且仅有一个S和E。

输出

对于每一组数据,输出阿尔吉侬吃到奶酪的最少单位时间。若阿尔吉侬无法吃到奶酪,则输出“oop!”(只输出引号里面的内容,不输出引号)。每组数据的输出结果占一行。

样例输入

3
3 4
.S..
###.
..E.
3 4
.S..
.E..
....
3 4
.S..
####
..E.

样例输出

5
1
oop!

分析

确定起点与终点的情况下求搜索深度,最通用的就是广搜了。不用记中间的变化状态,只记深度即可,deep多承担个是否已访问标记的作用。

实现

#include <cstring>
#include <queue>
#include <iostream>
using namespace std;
#define MAX (201 * 201)
char a[MAX];
int deep[MAX];
int r, c, sum;

int canMoveStep(int pos, int d);
int bfs(int start, int end) {
    memset(deep, 0, sizeof(deep));
    if (start == end) return 0;
    std::queue<int> q;
    q.push(start);
    while(!q.empty()) {
        int pos = q.front();
        q.pop();
        for(int i = 0; i < 4; i++) {
            int move = canMoveStep(pos, i);
            if (move) {
                int newPos = pos + move;
                if (a[newPos] !='#' && !deep[newPos]) {
                    deep[newPos] = deep[pos] + 1;
                    if (newPos == end) return deep[newPos];
                    q.push(newPos);
                }
            }
        }
    }
    return -1;
}

int canMoveStep(int pos, int d) {
    if (d == 0) return pos % c != 0 ? -1 : 0;   //第0列不能向左搜索
    if (d == 1) return (pos + 1) % c != 0;   //最后一列不能向右搜索
    if (d == 2) return pos < c ? 0 : -c;     //第0行不能向上搜索
    if (d == 3) return pos >= (sum - c) ? 0 : c;   //最后一行不能向下搜索
    return 0;
}

void print(int result)
{
    if (result == -1) {
        cout << "oop!" << endl;
    } else {
        cout << result << endl;
    }
}

int main() {
//  freopen("in.txt", "r", stdin);
    int t, start = 0, end = 0;
    cin >> t;
    while(t--) {
        cin >> r >> c;
        sum = r * c;
        for(int i = 0; i < sum; i++) {
            cin >> a[i];
            if (a[i] == 'S') {
                start = i;
            }else if (a[i] == 'E') {
                end = i;
            }
        }
        print(bfs(start, end));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值