小希的迷宫
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 36136 Accepted Submission(s): 11049
Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。
Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
整个文件以两个-1结尾。
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
Sample Output
Yes Yes No
#include<iostream>
#include<cstring>
using namespace std;
int room[100005];
int find(int x)
{
if(x==room[x])
return x;
else
while(x!=room[x])
x=room[x];
return x;
}
void merge(int x,int y)
{
room[find(room[x])]=find(y);
}
int count()
{
int sum=0;
for(int i=1;i<=100000;++i)
if(room[i]==i)
sum++;
return sum;
}
int main()
{
int a,b,i;
bool fit=true;
memset(room,0,sizeof(room));
while(cin>>a>>b&&!(a==-1&&b==-1))
{
if(!(a+b))
{
if(fit&&count()<=1)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
memset(room,0,sizeof(room));
fit=true;
continue;
}
if(room[a]==0)
room[a]=a;
if(room[b]==0)
room[b]=b;
if(!fit)
continue;
else if(find(a)==find(b))
fit=false;
else
merge(a,b);
}
return 0;
}