编译简单优先分析法

Ø6.2 设文法G[S]

SbAb,   A→ (B | a,   B→ Aa)
文法的简单优先关系矩阵:
是编写一个 简单优先关系算法,用于识别文法的句子,或句型;

输入

输入句子或句型

输出

判断句子或句型是否符合文法G[S]:

如果符合文法输出 accept

否则输出 not accept

样例输入

 
 
b((aa)a)b#

样例输出

 
 
accept
#include <iostream>
#include <stdio.h>
using namespace std;
const int N=1e5+5;
char s[N];
int p,flag;
void B();
void A()
{
    if(s[p]=='a')p++;
    else if(s[p]=='(')p++,B();
    else flag=1;
}
void B()
{
    A();
    if(s[p]=='a')
    {
        p++;
        if(s[p]==')')p++;
        else flag=1;
    }else flag=1;
}
void S()
{
    if(s[p]=='b')
    {
        p++,A();
        if(s[p]=='b')p++;
        else flag=1;
    }
    else flag=1;
}
int main()
{
    cin.getline(s,N);
    p=flag=0;
    S();
    if(s[p]=='#'&&!flag)puts("accept");
    else puts("not accept");
    return 0;
}

摘 要 编译程序的工作过程通常是词法分析、语法分析、语义分析、代码生成、代码优化。编译程序的这些过程的执行先后就构成了编译程序的逻辑结构,但是这些逻辑结构不一定是按照某一个固定顺序的,也有可能是按照平行或者互锁的方式执行的。 本次课程计是就简单优先文法原理来做一个简单优先分析器。简单优先分析文法的基本思想是对一个文法按一定的原则求出该文法所有符号包括终结符和非终结符之间的优先关系,按照这种关系确定规约过程中的句柄,它的规约过程实际上是规范规约。在算法实现过程中,主要使用visual C++进行编程。 关键字 简单优先关系 大于关系 小于关系 等于关系 Abstract Compiler of the process is usually lexical analysis, grammar analysis, semantic analysis, code generation, code optimization. Compiler of the implementation of these processes have posed a compiler on the logical structure, but these may not necessarily be in accordance with the logical structure of a fixed order, may also be in accordance with the parallel or interlocking approach to the implementation of the. This course is designed on the simple principle of priority to do a simpegrammar priority Analyzer。Simple grammar priority of the basic idea of a grammar obtained by certain principles of the grammar, including all the symbos at the end and at the end of the non-priority, according to this relationship in the process of determining the statute handler, it is actually the process of regulating the Statute of the Statute. In the algorithm process, the main use of visual C programming. Key Words Simple priority relations Over relations Less than relations Equal relations 目 录 摘要…………………………………………………………………………………………2 一、概述……………………………………………………………………………………4 (一)实验环境与开发工具 ………………………………………………………‥4 (二)简单优先文法简介 ……………………………………………………………4 (三)基本概念 ………………………………………………………………………4 (四)优先关系 ………………………………………………………………………4 二、需求分析 ……………………………………………………………………………5 (一)总体功能需求 …………………………………………………………………5 (二)系统的主要功能函数 …………………………………………………………5 (三)系统的计思想 ………………………………………………………………6 三、详细计 ……………………………………………………………………………7 (一)等于关系模块 …………………………………………………………………7 (二)小于关系模块 …………………………………………………………………8 (三)大于关系模块 …………………………………………………………………10 (四)句子识别模块 …………………………………………………………………12 四、测试结果………………………………………………………………………………16 五、小结……………………………………………………………………………………19 六、参考文献 ……………………………………………………………………………20 附录 源程序 ………………
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值