poj1579

Function Run Fun
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 12713
Accepted: 6621

Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


解析

  这本身就是一个递归函数,要是按照函数本身写递归式,结果肯定是TLE,这里我开了一个三维数组,从w(0,0,0)开始递推,逐步产生到w(20,20,20)的值,复杂度O(n^3).

这道题是很地道的DP,因为它的子问题实在是太多了,所以将问题的结果保存起来.这个例子就非常典型。总体来说这个题目还是非常简单的,不过这个思想是地道的动态规划。



参考代码

#include<stdio.h>

#define max_n 21
int main(){
    int ava[max_n][max_n][max_n];
    int i,j,k;
    int a,b,c;
    for(i=0;i<=20;i++)
for(j=0;j<=20;j++){
ava[i][j][0]=1;
ava[i][0][j]=1;
ava[0][i][j]=1;
}
for(i=1;i<=20;i++)
for(j=1;j<=20;j++)
for(k=1;k<=20;k++){
if(i<j&&j<k)
ava[i][j][k]=ava[i][j][k-1]+ava[i][j-1][k-1]-ava[i][j-1][k];
else
ava[i][j][k]=ava[i-1][j][k]+ava[i-1][j-1][k]+ava[i-1][j][k-1]-ava[i-1][j-1][k-1];
}
while(true){
scanf("%d%d%d",&a,&b,&c);
if(a==-1&&b==-1&&c==-1)break;
if(a<=0||b<=0||c<=0)printf("w(%d, %d, %d) = %d\n",a,b,c,1);
else if(a>=20||b>=20||c>=20)printf("w(%d, %d, %d) = %d\n",a,b,c,ava[20][20][20]);
else
printf("w(%d, %d, %d) = %d\n",a,b,c,ava[a][b][c]);
}
return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值