PAT (Advanced Level) Practice 1030 Travel Plan 最短路径满足最小花费

题目:
PAT 1030 Travel Plan
A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output:
0 2 3 3 40

分析:
很明显直白的最短路径问题,但是多了边上除了距离,还多了一个权值代表花费,同时最后还需要输出路径。这里,我们仍然选择最短路的板子。我们可以用Dijkstra,将花费与距离分离出来,即我们用两个二维数组来存图,一个得到边代表距离,另一个的边代表花费。因此,我们就很容易想到同样需要两个存储类似于dis的数组。由于要输出路径,我们还需要一个path数组来存储该点的上一个点,且经过多次更新之后,这两点连接成的边一定是满足最优解的。最后由一个递归函数来输出路径。

代码:

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
typedef long long ll;
const int maxn=505;
const int inf=0x3f3f3f3f;
int n,m,s,d;
int u,v,k,w,ans;
int mp[maxn][maxn],cst[maxn][maxn];
int vis[maxn],dis[maxn],path[maxn],cs[maxn];
void dfs(int u){
    if(u == s){
    //出口就是到了起点,因为我们从终点开始递归
        printf("%d", s);
        return;
    }
    dfs(path[u]);
    printf(" %d", u);
}
int main(){
	scanf("%d%d%d%d",&n,&m,&s,&d);
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			if(i!=j) mp[i][j]=cst[i][j]=inf;
			else mp[i][j]=cst[i][j]=0;
		}
	}
	while(m--){
		scanf("%d%d%d%d",&u,&v,&k,&w);
		mp[u][v]=mp[v][u]=k;
		cst[u][v]=cst[v][u]=w;
	}
	for(int i=0;i<n;i++){
		dis[i]=inf;
		cs[i]=inf;
		path[i]=-1;
	}
	dis[s]=cs[s]=0;
	for(int i=0;i<n;i++){
		int kmin=inf,km=0;
		for(int j=0;j<n;j++){
			if(vis[j]==0&&kmin>dis[j]){
				kmin=dis[j];
				km=j;
			}
		}
		vis[km]=1;
		for(int j=0;j<n;j++){
			if(!vis[j]&&dis[j]>dis[km]+mp[km][j]){
				cs[j]=cs[km]+cst[km][j];
				dis[j]=dis[km]+mp[km][j];
				path[j]=km;
			}
			else if(!vis[j]&&dis[j]==dis[km]+mp[km][j]&&cs[j]>cs[km]+cst[km][j]){
				cs[j]=cs[km]+cst[km][j];
				path[j]=km;
			}
		}
	}
	dfs(d);
	printf(" %d %d\n",dis[d],cs[d]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

tran_sient

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值