PAT 10.4 A 1030 Travel Plan (30 分)(最短路径及最小花费——Dijkstra算法)

1030 Travel Plan (30 分)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

题意为求最短路径,最短距离及最小花费,若 最短距离相同,则输出花费最小的。

参考代码:

#include <cstdio>
#include <cstring>
#include <vector> 
#include <algorithm>
using namespace std;
const int maxv=520;
const int INF=1000000000;
//n为顶点数,m为边数,Start为起点,End为终点
//G为邻接矩阵,cost为花费 
//d为最短距离,mincost 记录路径上的最小花费
int n,m,Start,End;
int G[maxv][maxv],cost[maxv][maxv];
int d[maxv],mincost=INF; 
vector<int> pre[maxv];//pre存放每个结点的前驱 
vector<int> temp,path; //临时路径,最优路径 
bool vis[maxv]={false};

void Dijkstra(int s)
{
	fill(d,d+maxv,INF);
	d[s]=0;
	for(int i=0;i<n;++i)
	{
		int u=-1,min=INF;
		for(int j=0;j<n;++j)
		{
			if(vis[j]==false&&d[j]<min)
			{
				u=j;
				min=d[j];
			}
		}
		if(u==-1)
			return;
		vis[u]==true;
		for(int v=0;v<n;++v)
		{
			if(vis[v]==false&&G[u][v]!=INF)
			{
				if(d[u]+G[u][v]<d[v]) 
				{
					d[v]=d[u]+G[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if(d[u]+G[u][v]==d[v])
				{
					pre[v].push_back(u);
				} 		
			}
		}
	}
} 

void DFS(int v) //v为当前访问结点
{
	if(v==Start) //递归边界,到达叶子结点 
	{
		temp.push_back(v);
		int tempcost=0; //记录当前路径上的花费之和
		for(int i=temp.size()-1;i>0;--i)
		{
			int id=temp[i],nextid=temp[i-1];
			tempcost+=cost[id][nextid];
		}
		if(tempcost<mincost)
		{
			mincost=tempcost; //更新最小花费 
			path=temp;// 更新path 
		}
		temp.pop_back();
		return ; 
	}
	temp.push_back(v);
	for(int i=0;i<pre[v].size();++i)
		DFS(pre[v][i]);
	temp.pop_back();
}

int main()
{
	scanf("%d%d%d%d",&n,&m,&Start,&End);
	int u,v;
	fill(G[0],G[0]+maxv*maxv,INF);
	fill(cost[0],cost[0]+maxv*maxv,INF); 
	for(int i=0;i<m;++i)
	{
		scanf("%d%d",&u,&v);
		scanf("%d%d",&G[u][v],&cost[u][v]);
		G[v][u]=G[u][v];
		cost[v][u]=cost[u][v];
	}
	Dijkstra(Start);
	DFS(End);
	for(int i=path.size()-1;i>=0;--i)
	{
		printf("%d ",path[i]); //由于递归是逆序的,固倒着输出路径上的结点 
	}
	printf("%d %d\n",d[End],mincost);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值