HDU1250 Hat's Fibonacci

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7818    Accepted Submission(s): 2543


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define M 8000
int num[M][700]={{1},{1},{1},{1},{1}};
void f()
{
	int i,j,s=0;
	for(i=5;i<M-1;i++)
		for(j=0;j<699;j++)
		{
			s+=num[i-4][j]+num[i-3][j]+num[i-2][j]+num[i-1][j];
			num[i][j]=s%10000;
			s=s/10000;
		}
	while(s)
	{
		num[i][j++]=s%10000;
		s=s/10000;
	}
}
int main()
{
	int n;
	int i,j;
	f();
	while(scanf("%d",&n)!=EOF)
	{
		for(i=690;num[n][i]==0;i--)
			;
		printf("%d",num[n][i]);
		for(j=i-1;j>=0;j--)
			printf("%04d",num[n][j]);
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值