hdu 1250 Hat's Fibonacci

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250

 

题目描述:

 

Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1. 
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4) 
Your task is to take a number as input, and print that Fibonacci number. 

Input

Each line will contain an integers. Process to end of file. 

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

 

 

题目分析:

二维数组,但是如果每个位置存储10(即0~9中的某一个)会超内存,所以在这里我每个位置存储8位数(即0~100000000)

 

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#define MOD 100000000
using namespace std;
int v[8000][305];
void Init()
{
     v[1][1]=1;
     v[2][1]=1;
     v[3][1]=1;
     v[4][1]=1;
     for(int i=5;i<8000;i++)
     {
         for(int j=1;j<300;j++)
            v[i][j]=v[i-1][j]+v[i-2][j]+v[i-3][j]+v[i-4][j];
         for(int j=1;j<300;j++)
         {
             if(v[i][j]/MOD)
             {
                 v[i][j+1]+=(v[i][j]/MOD);
                 v[i][j]%=MOD;
             }
         }
     }
}
int main()
{
    Init();
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int k;
        for(k=300;k>=1;k--)
        {
            if(v[n][k])
                break;
        }
        printf("%d",v[n][k]);
        for(int j=k-1;j>=1;j--)
        {
            printf("%08d",v[n][j]);
        }
        printf("\n");
    }
    return 0;
}

 

 

 

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值