ACM书中的题目 U-21

U-21

Description
Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?

Input
The input consists of one or more test cases. For each test case, there is a single line containing an integer N.

Output
For each test case in the input, output the result on a line by itself.

Sample Input
1
2
3
4

Sample Output
3
5
6
9
题意描述:
多组数据进行测试,输入一个整数n输入对应的第n个能被3或5整除的数
解题思路:
用for循环,不能进行确定最大数,可以先定义一个数为3,加一之后看是否符合,然后在相加,直到符合条件的数大于1000000
解题细节:
多组数据,使用while循环,先将1000000以内符合条件的算出来,在输入第n个时,别忘了需要减一
代码:

#include<bits/stdc++.h>  
using namespace std;  
int main()  
{  
    vector<int>v;  
    int n,i=3,m;  
    v.clear();  
    while(1)  
    {  
        if(n>1000000)  
        break;  
        if(i%3==0||i%5==0)  
        {  
            v.push_back(i);  
            n++;  
        }  
        i++;}  
        while(cin>>m)  
    {   cout<<v[m-1]<<endl;}  
    return 0;
    }  

体会:
看起来题目不是很难,但程序并不好想,还需要锻炼

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值