《ACM程序设计》书中题目―U

Description
Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?
Input
The input consists of one or more test cases. For each test case, there is a single line containing an integer N.
Output
For each test case in the input, output the result on a line by itself.
Sample Input
1
2
3
4

Sample Output
3
5
6
9

1、题意:能被3或5整除的数为美丽数,让你输入n,输出n个美丽数。
2、思路:这题还是使用map,让n为key,存储美丽数,再输出即可。
3、代码:
#include<iostream>
#include<map>
#include<string>
using namespace std;
int main()
{
map<int,int> n;
int i,t=1,x=1;
while(1)
{
if(t>100000)
break;
if(x%3==0||x%5==0)
{
n[t]=x;
t++;
}
x++;
}
while(cin>>i)
{
cout<<n[i]<<endl;
}
return 0;
}
4、总结:map可以用在各种问题中,解决问题十分方便。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值