ZOJ 3826 Hierarchical Notation(2014 牡丹江 B,树的直径+二分)

Building Fire Stations

Time Limit: 5 Seconds      Memory Limit: 131072 KB      Special Judge

Marjar University is a beautiful and peaceful place. There are N buildings andN - 1 bidirectional roads in the campus. These buildings are connected by roads in such a way that there is exactly one path between any two buildings. By coincidence, the length of each road is 1 unit.

To ensure the campus security, Edward, the headmaster of Marjar University, plans to setup two fire stations in two different buildings so that firefighters are able to arrive at the scene of the fire as soon as possible whenever fires occur. That means the longest distance between a building and its nearest fire station should be as short as possible.

As a clever and diligent student in Marjar University, you are asked to write a program to complete the plan. Please find out two proper buildings to setup the fire stations.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 200000).

For the next N - 1 lines, each line contains two integers Xi andYi. That means there is a road connecting building Xi and buildingYi (indexes are 1-based).

Output

For each test case, output three integers. The first one is the minimal longest distance between a building and its nearest fire station. The next two integers are the indexes of the two buildings selected to build the fire stations.

If there are multiple solutions, any one will be acceptable.

Sample Input
2
4
1 2
1 3
1 4
5
1 2
2 3
3 4
4 5
Sample Output
1 1 2
1 2 4
 
题目大意:
给你一棵树,每条边边权都是1,找2个不同的哨兵点,使得所有的点到最近的哨兵点的距离的最大值最小。
解题思路:
由于是求最大值最小问题,那么一般会想到二分答案求解。
那么问题来了,二分一个答案之后如果安放这两个点的位置。考虑到树的直径。由于是最大值,所以这两个点到两个直径端的距离 应该等于二分的答案X.然后在判断其他点
到这2个点的距离的最大值。如果小于等于X的话 说明X满足答案。否则X不满足 那么再小的也不满足。
 
 
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#define MOD 1000000007
#define eps 1e-8
#define maxn 200000+10
#define maxm 400000+10


using namespace std;

struct Edge
{
    int from,to,next;
}es[maxm];
int cnt,p[maxn];
int pre[maxn];

void add(int x,int y)
{
    es[cnt].from = x;
    es[cnt].to = y;
    es[cnt].next=  p[x];
    p[x] = cnt++;
}

int dis[maxn];
int used[maxn];

void init()
{
    memset(p,-1,sizeof p);
   // memset(used,0,sizeof used);
    cnt = 0;
}
int n,st,en;
int maxlen;

void bfs(int u)
{
    memset(used,0,sizeof(used));
    memset(dis,0x7F,sizeof(dis));
    dis[u]=0;
    used[u]=1;
    queue<int>q;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        if(dis[u]>maxlen)
        {
            maxlen=dis[u];
            st=u;
        }
        for(int i = p[u];~i;i = es[i].next)
        {
            int v = es[i].to;
            if(used[v]) continue;
            used[v] = 1;
            dis[v] =dis[u]+1;
            q.push(v);
        }
    }
}

void bfs1(int u)
{
    memset(used,0,sizeof(used));
    memset(dis,0x7F,sizeof(dis));
    dis[u]=0;
    used[u]=1;
    queue<int>q;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        if(dis[u]>maxlen)
        {
            maxlen=dis[u];
            en=u;
        }
        for(int i = p[u];~i;i = es[i].next)
        {
            int v = es[i].to;
            if(used[v]) continue;
            used[v] = 1;
            dis[v] =dis[u]+1;
            pre[v]=u;
            q.push(v);
        }
    }
}
void bfs2(int u)
{
    memset(used,0,sizeof(used));
    dis[u]=0;
    used[u]=1;
    queue<int>q;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(int i = p[u];~i;i = es[i].next)
        {
            int v = es[i].to;
            if(used[v]) continue;
            used[v] = 1;
            dis[v] = min(dis[v],dis[u]+1);
            q.push(v);
        }
    }
}

int l1,l2;

bool judge(int x)
{
    l1 = en;
    l2 = en;
    int t = x;
    if(t<0) return 0;
    while(t--)
    {
        l1 = pre[l1];
    }
    t = maxlen -x ;
    if(t<0) return 0;
    while(t--)
    {
        l2 = pre[l2];
    }
    if(l2 == l1)
        l2 = pre[l2];
    memset(dis,0x7F,sizeof dis);
    dis[l1]=0;

    bfs2(l1);
    dis[l2]=0;
    bfs2(l2);
   // if(x==1)
    //    for(int i=1;i<=n;i++) cout<<dis[i]<<' ';
   // cout<<endl;
    for(int i=1;i<=n;i++)
        if(dis[i]>x) return 0;
    //if(!dfs2(l1,-1,x)) return 0;
   // if(!dfs2(l2,-1,x)) return 0;
    return 1;
}

int main()
{

    int T;
    scanf("%d",&T);
    for(int ks = 1;ks <= T;ks++)
    {
        scanf("%d",&n);
        init();
        for(int i = 0;i < n-1;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            add(x,y);
            add(y,x);
        }
        maxlen = 0;
        memset(dis,0,sizeof dis);
        memset(used,0,sizeof used);
        bfs(1);
        maxlen = 0;
        memset(dis,0,sizeof dis);
        memset(used,0,sizeof used);
        bfs1(st);

        int ans = 0;
        int ans1,ans2;
        int l = 0,r= maxlen/2;
        while(l <= r)
        {
            int mid = (l+r)>>1;
            if(judge(mid))
            {
                ans = mid;
                r= mid-1;
                ans1 = l1;
                ans2 = l2;
            }
            else l = mid+1;
          //  cout<<"fsd"<<endl;
        }
        printf("%d %d %d\n",ans,ans1,ans2);
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值