Microsoft Visual C++ 14.0 is required 的解决方案

        个人认为Python的一大亮点就是对于我们在学习中遇到的常见问题,它都有很多现成的module可供使用,但是,在我们安装这些module时,可能会出现**“error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”**这样的错误。对于此类问题,提供以下两种解决方案:

1 下载所需模块的.whl文件,然后再以pip的形式安装:
1)常用模块的.whl文件的下载地址:Unofficial Windows Binaries for Python Extension Packages
2)以模块Twisted为例,我们再下载了该模块的.whl文件后,在控制台通过以下命令安装
         pip install Twisted‑18.9.0‑cp27‑cp27m‑win32.whl

2 最根本的解决办法:按照错误提示,需要安装Microsoft Visual C++ 14.0才能解决问题,那我们安装一下应该就没问题了(亲测可用不坑人):
1)Microsoft Visual C++ 14.0的百度云下载地址为:
      https://pan.baidu.com/s/12TcFkZ6KFLhofCT-osJOSg 提取码:wkgv

©️2020 CSDN 皮肤主题: 精致技术 设计师:CSDN官方博客 返回首页