POJ1328(雷达安装)

Description


Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
POJ1328(雷达安装) - tuchengju - tuchengju的博客
Figure A Sample Input of Radar Installations

Input


The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros

Output


For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2  
1 2  
-3 1
2 1    
 
1 2  
0 2    
 
0 0  

Sample Output

Case 1: 2  
Case 2: 1  

 

#include<iostream>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<functional>
#include<iomanip>
#include<vector>

using namespace std;

struct RadarScope
{
public:
    RadarScope (double nStart, double nEnd)
        : m_nStart (nStart), m_nEnd (nEnd)
    { }
    RadarScope ()
        : m_nStart (0), m_nEnd (0)
    { }
    friend
    bool operator < (const RadarScope& lth, const RadarScope& rth)
    {
        return lth.m_nStart < rth.m_nStart ;
    }
    public:
    double m_nStart ;
    double m_nEnd ;
} ;

int main()
{
  int n=0,d=0;
  vector<int> result;
  double temp;
 
  cin>>n>>d;
  while (n!=0||d!=0)
  {
        int x,y;
        vector<RadarScope> scope;
        bool isSoluted=true;
        for (int i=0;i<n;i++)
        {
            cin>>x>>y;
            if (d<y||y<0)
               isSoluted=false;
            double r=d*d-y*y;
            double start=x-sqrt(r);
            double end=x+sqrt(r);
            scope.push_back(RadarScope(start,end));      
        }
        if (isSoluted)
        {
            sort (scope.begin(), scope.end()) ;
 //           for (vector<RadarScope>::iterator ite = scope.begin() ;
  //              ite != scope.end() ;
  //              ++ ite)
  //          cout << ite->m_nStart << ", "<< ite ->m_nEnd << endl ;
            temp=scope[0].m_nEnd;
            int lastend=0;
            for (int i=1;i<n;i++)
                if (scope[i].m_nStart>temp){
                   lastend++;
                   temp=scope[i].m_nEnd;
                }
                else if (scope[i].m_nEnd<temp)
                        temp=scope[i].m_nEnd;
                  
            result.push_back(lastend+1);                
        }else
            result.push_back(-1);
        char choice = getchar();
        cin>>n>>d;
  }   
 
  for (int i=0;i<result.size();i++)
      cout<<"Case "<<(i+1)<<": "<<result[i]<<endl;
           
 // system("pause");
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值