PAT (Advanced Level) 1032. Sharing (25) 求链表第一个交点,测试用例不保证有交点

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
使用数组作为静态链表,每个结点的值为下一个地址,如a[67890]=00002。
使用set哈希表记录第一个链表访问过的所有结点,遇到-1退出,或者又回到访问过的点,表明有环,也退出。
同样的记录第二个链表访问过的点,若遇到某点存在于第一个链表的哈希表,直接打印结果,结束程序。同样的遇到-1或者有环也退出,输出-1。
/*2015.7.23cyq*/
#include <iostream>
#include <vector>
#include <set>
using namespace std;

int main(){
	int N,H1,H2;
	cin>>H1>>H2>>N;
	vector<int> L(100000);
	set<int> visited1,visited2;
	int addr,next;
	char ch;
	for(int i=0;i<N;i++){
		scanf("%d %c %d",&addr,&ch,&next);
		L[addr]=next;
	}
	int p1=H1,p2=H2;
	while(p1!=-1){//记录所有p1访问过的点
		if(visited1.find(p1)==visited1.end()){
			visited1.insert(p1);
		}else//又到了访问过的点,有环
			break;
		p1=L[p1];
	}
	while(p2!=-1){
		if(visited1.find(p2)!=visited1.end()){
			printf("%05d",p2);
			return 0;
		}
		if(visited2.find(p2)==visited2.end()){
			visited2.insert(p2);
		}else//有环
			break;
		p2=L[p2];
	}
	printf("-1");
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值