PAT (Advanced Level) 1052. Linked List Sorting (25) 结构体排序

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1
先用一个数组作为静态链表,存储输入结点,根据静态链表把相关结点存入res结果数组,对res数组进行排序后,修正每个结点的后继结点,然后进行输出。
/*2015.7.26cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct LNode{
	int address;
	int val;
	int next;
};

bool cmp(const LNode &a,const LNode &b){
	return a.val<b.val;
}

int main(){
	int N,head;
	cin>>N>>head;
	vector<LNode> L(100000);

	int x;
	for(int i=0;i<N;i++){
		cin>>x;
		L[x].address=x;
		cin>>L[x].val;
		cin>>L[x].next;
	}
	
	vector<LNode> res;//存储从head开始的有关结点
	int p=head;
	while(p!=-1){
		res.push_back(L[p]);
		p=L[p].next;
	}

	sort(res.begin(),res.end(),cmp);
	//排序后修正后继结点
	int len=res.size();
	if(len==0){
		printf("0 -1\n");
		return 0;
	}
	res[len-1].next=-1;
	for(int i=len-2;i>=0;i--)
		res[i].next=res[i+1].address;

	printf("%d %05d\n",len,res[0].address);
	for(int i=0;i<len-1;i++)
		printf("%05d %d %05d\n",res[i].address,res[i].val,res[i].next);
	printf("%05d %d %d\n",res[len-1].address,res[len-1].val,res[len-1].next);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值