PAT (Advanced Level) 1053. Path of Equal Weight (30) 求树根到叶子和为所给数值的路径,DFS后排序

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
DFS后进行使用STL的sort进行排序,自定义比较方法,注意STL的sort规定相等时必须返回false,以保证稳定排序。
/*2015.7.27cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <fstream>
using namespace std;

//fstream fin("case1.txt");
//#define cin fin

struct TNode{
	int val;
	vector<int> next;
};

void dfs(const vector<TNode> &tree,int root,int target,vector<int> &path,vector<vector<int> > &result){
	path.push_back(tree[root].val);
	target-=tree[root].val;
	if(tree[root].next.empty()){//叶子结点
		if(target==0)
			result.push_back(path);
	}else{
		for(auto it=tree[root].next.begin();it!=tree[root].next.end();it++){
			dfs(tree,*it,target,path,result);
		}
	}
	target+=tree[root].val;
	path.pop_back();
}
bool cmp(const vector<int> &a,const vector<int> &b){
	if(a==b)//注意STL的sort规定相等时必须返回false
		return false;
	int n=a.size();
	int m=b.size();
	int i=0;
	while(i<n&&i<m){
		if(a[i]>b[i])
			return true;
		else if(a[i]<b[i])
			return false;
		else 
			i++;
	}
	if(i==m)
		return true;
	return false;
}
int main(){
	int N,M,S;
	cin>>N>>M>>S;
	vector<TNode> tree(N);
	for(int i=0;i<N;i++)
		cin>>tree[i].val;
	int addr,num,x;
	for(int i=0;i<M;i++){
		cin>>addr>>num;
		for(int i=0;i<num;i++){
			cin>>x;
			tree[addr].next.push_back(x);
		}
	}

	vector<int> path;
	vector<vector<int> > result;
	dfs(tree,0,S,path,result);
	
	sort(result.begin(),result.end(),cmp);
	for(auto it=result.begin();it!=result.end();++it){
		auto ik=(*it).begin();
		cout<<*ik;
		for(ik=(*it).begin()+1;ik!=(*it).end();ik++){
			cout<<" "<<*ik;
		}
		cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值