PAT (Advanced Level) 1083. List Grades (25) 结构体排序

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE
/*2015.7.30cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct stu{
	string name;
	string id;
	int score;
};

bool cmp(const stu &a,const stu &b){
	return a.score>b.score;
}
int main(){
	int N;
	cin>>N;
	vector<stu> stus(N);
	for(int i=0;i<N;i++){
		cin>>stus[i].name>>stus[i].id>>stus[i].score;
	}
	sort(stus.begin(),stus.end(),cmp);
	int low,high;
	cin>>low>>high;
	vector<stu> result;
	for(int i=0;i<N;i++){
		if(stus[i].score>=low&&stus[i].score<=high)
			result.push_back(stus[i]);
	}
	if(result.empty())
		cout<<"NONE";
	else{
		for(auto it=result.begin();it!=result.end();++it)
			cout<<(*it).name<<" "<<(*it).id<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
下面是对代码的一些优化建议: 1. 头文件可以更改为`#include <stdlib.h>`来使用`malloc`函数,这是标准库头文件。 2. 可以使用`typedef`来简化结构体的声明,如下所示: ``` typedef struct { int id, grades; } Information; ``` 3. 在动态分配内存时,应该检查是否分配成功,如果分配失败,则应该处理错误。 4. 冒泡排序是一个比较慢的排序算法,可以考虑使用更快的排序算法,如快速排序。 5. 在找到排名时,可以使用一个变量来保存排名,而不是修改`m`的值。 下面是优化后的代码: ``` #include <stdio.h> #include <stdlib.h> typedef struct { int id, grades; } Information; int cmp(const void *a, const void *b) { Information *p = (Information *)a; Information *q = (Information *)b; if (p->grades != q->grades) { return q->grades - p->grades; } else { return p->id - q->id; } } int main() { int n, m, grades; scanf("%d %d", &n, &m); m = (int)(m * 1.5); Information *p = (Information *)malloc(n * sizeof(Information)); if (p == NULL) { printf("Memory allocation failed.\n"); return 1; } for (int i = 0; i < n; i++) { scanf("%d %d", &p[i].id, &p[i].grades); } qsort(p, n, sizeof(Information), cmp); grades = p[m - 1].grades; int rank = m; for (int i = m; i < n && p[i].grades == grades; i++) { rank++; } printf("%d %d\n", grades, rank); for (int i = 0; i < rank; i++) { printf("%d %d\n", p[i].id, p[i].grades); } free(p); return 0; } ``` 优化后的代码使用了`qsort`函数进行排序,时间复杂度为$O(nlogn)$,比冒泡排序的$O(n^2)$要快得多。在找到排名时,使用了一个变量来保存排名,而不是修改`m`的值。同时,在动态分配内存时检查了分配是否成功。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值