PAT (Advanced Level) 1085. Perfect Sequence (25) 贪心算法

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
排序后使用贪心算法。
/*2015.7.30cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
	long long N,p;
	cin>>N>>p;
	vector<long long> ivec(N);
	for(int i=0;i<N;i++)
		cin>>ivec[i];

	sort(ivec.begin(),ivec.end());
	int low=0;
	int high=0;
	int len=0;
	while(1){
		while(high<N&&ivec[high]<=ivec[low]*p)
			high++;
		if(high-low>len)
			len=high-low;
		if(high==N)
			break;
		while(low<high&&ivec[low]*p<ivec[high])
			low++;
	}
	cout<<len;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值