公共字串计算

题目标题:

计算两个字符串的最大公共字串的长度,字符不区分大小写

接口说明:

原型: int getCommonStrLength(char * pFirstStr, char * pSecondStr);

输入参数:
char * pFirstStr //第一个字符串

char * pSecondStr//第二个字符串

知识点: 字符串,查找

输入: 字符串1 字符串2

输出: 整数

样例输入: asdfas werasdfaswer

样例输出: 6

代码:

#include <iostream>  
#define MAX 200  
using namespace std;  
void Transfer(char* str,int len)  
{  
    for (int i = 0; i < len; i++)  
        if (str[i] >= 'A'&&str[i] <= 'Z')  
            str[i] += 'a' - 'A';  
} 
int main()  
{  
    char str1[MAX], str2[MAX];  
    cin >> str1 >> str2;  
    int len1 = strlen(str1), len2 = strlen(str2);  
    int i, j, max = 0, count = 0, m, n;  
    Transfer(str1, len1);  
    Transfer(str2, len2);  
    for (i = 0; i < len1; i++)   
        for (j = 0; j < len2; j++)  
        {  
            m = i; n = j;  
            while (str1[m] == str2[n]&&m<len1&&n<len2)  
            {  
                count++;  
                m++;  
                n++;  
            }  
            if (count > max)  
                max = count;  
            count = 0;  
        }    
    cout << max << endl;  
    return 0;  
}
得分运行时间内存复杂度最大嵌套深度
450(450)31ms2048KB74
注意:

该代码的时间复杂度在字符串较大的情况下很大,这是很笨的办法。

看到网上的优化算法是动态规划问题。目前,还没有时间仔细研究,等把所有题目刷一遍,定来好好钻研。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值