在字符串中找出连续最长的数字串

题目描述:

样例输出:

输出123058789,函数返回值9
输出54761,函数返回值5
 
接口说明:
函数原型:
   unsignedint Continumax(char** pOutputstr,  char* intputstr)
输入参数:
   char* intputstr  输入字符串;
输出参数:
   char** pOutputstr: 连续最长的数字串,如果连续最长的数字串的长度为0,应该返回空字符串;如果输入字符串是空,也应该返回空字符串;  
返回值:
   连续最长的数字串的长度

知识点: 位运算

输入: 字符串。

输出: 字符串中最长的数字字符串, 它的长度

如果数字字符串为空,则只输出0。如 input: dadfsaf  output:0

样例输入: 

abcd12345ed125ss123058789

样例输出: 

123058789,9

代码:

#include <iostream>
#define MAX 100
using namespace std;
int main()
{
	char str[MAX];
	cin.getline(str, MAX);
	int len = strlen(str), i, count,max=0,index;
	for (i = 0; i < len; i++)
	{
		count = 0;
		while (str[i] >= '0'&&str[i] <= '9')
		{
			count++;
			i++;
		}
		if (count > max)
		{
			max = count;
			index = i - count;
		}
	}
	if (max != 0)
	{

		for (i = index; i < index + max; i++)
			cout << str[i];
		cout << "," << max << endl;
	}
	else
		cout << 0 << endl;
	return 0;
}
得分运行时间内存复杂度最大嵌套深度
98(100)16ms2048KB83

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值