题目链接:点击打开链接
本题目要求读入2个整数N和M,m表示小金字塔的行数,n代表大金字塔的层数。然后输出多层金字塔。
输入格式:
输入在一行中正整数N和M。
输出格式:
对每一组输入,显示对应的图案。
输入样例:
2 3
输出样例:
<span style="font-size:18px;">#include <iostream>
#include<cstdio>
using namespace std;
int main(int argc, char** argv) {
int n,m;
cin>>n>>m;
int y,w;
for(int i=1,j=1;i<=m;i++,j=j+2)
{
w=j;
}
int q,p;
p=m*(n-1);
q=1;
while(p>-m)
{
y=w;
for(int i=1,j=1;i<=m;i++,j=j+2)
{
for(int k=1;k<=p;k++)
{
cout<<" ";
}
for(int t=1;t<=q;t++)
{
if(t==1)
{
for(int k=1;k<=m-i;k++)
{
cout<<" ";
}
for(int k=1;k<=j;k++)
{
cout<<"*";
}
}
else
{
for(int k=1;k<=y;k++)
{
cout<<" ";
}
for(int k=1;k<=j;k++)
{
cout<<"*";
}
}
}
cout<<endl;
y=y-2;
}
q++;
p=p-m;
}
}</span>