poj 3278 Catch That Cow

题目链接:点击打开链接

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4
题目大意:给出牛的位置和人的位置,人可以向前走一步,和向后退一步,和跳到原位置的二倍处
问最短走多少步可以追到牛,坐标不可以是负的,不可以超过100000
基本思路:简单的bfs,将人走的每一步放到队列中,人可行的下一个位置放到队列中,注意不可以重复走过的位置,所以要标记.要注意位置的大小判断.这个我卡在了边界上,还有就是不能重复走过的位置上
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
#define INF 0x3f3f3f3f
struct node
{
    int data;
    int step;
} now,next;
int n,k;
int vis[100100];
queue<struct node>q;
int bfs()
{
    while(!q.empty())
    {
        q.pop();
    }
    now.data=n;
    now.step=0;
    vis[now.data]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        //next=now;
        for(int i=0; i<3; i++)
        {
            if(i==0)
            {
                next.data=now.data-1;
            }
            if(i==1)
            {
                next.data=now.data+1;
            }
            if(i==2)
            {
                next.data=now.data*2;
            }
            next.step=now.step+1;
            if(next.data==k)return next.step;
            if(next.data<0||next.data>100000)continue;
            if(vis[next.data]==0)
            {
                q.push(next);
                vis[next.data]=1;
            }
        }
    }
    return INF;
}
int main()
{
    while(cin>>n>>k)
    {
        memset(vis,0,sizeof(vis));
        if(n<k)
        {
            cout<<bfs()<<endl;
        }
        else if(n==k)
        {
            cout<<"0"<<endl;
        }
        else cout<<n-k<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值