poj 2418 Hardwood Species

题目链接:点击打开链接

Description

Hardwoods (硬木) are the  botanical (植物学的) group of trees that have broad leaves, produce a fruit or nut, and generally go  dormant (休眠的) in the winter. 
America's  temperate (温和的) climates produce forests with hundreds of hardwood  species (物种) -- trees that share certain  biological (生物的)  characteristics (特征). Although oak, maple and  cherry (樱桃) all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States. 

On the other hand,  softwoods (软木材), or  conifers (针叶树), from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include  cedar (雪松), fir,  hemlock (铁杉), pine,  redwood (红木树), spruce (云杉) and  cypress (柏树). In a home, the softwoods are used primarily as  structural (结构的)  lumber (木材) such as 2x4s and 2x6s, with some limited  decorative (装饰性的) applications. 

Using satellite imaging technology, the Department of Natural Resources has  compiled (编译) an  inventory (存货) of every tree standing on a particular day. You are to compute the total  fraction (分数) of the tree population represented by each species.

Input

Input (投入) to your program consists of a list of the  species (物种) of every tree observed by the satellite; one tree per line. No species name  exceeds (超过) 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in  alphabetical (字母的) order, followed by the percentage of the population it represents, to 4  decimal (小数) places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483
题意:给出很多字符串,求出每个字符串出现的概率,按字典序输出,题意很简单,正常做法就是字典树计数;
ps:为了偷懒特意百度map的用法,(map用的不熟练)
注意输入流和输出流的使用,输出是G++用.f,C++用.lf

getline(cin,s),s需要是string,需要引入string头文件,std::string空间引入

cin.getline适合你知道读入大小,固定char数组,速度快

getline(cin,s)不需要指定大小,但速度慢、生成的文件大,适合偷懒用
还要注意用longlong 
#include <iostream>
#include<cstring>
#include<map>
#include<cstdio>
using namespace std;

int main()
{
    //ios::sync_with_stdio(false);//曾快速度的
    map<string,int >mp;
    string x;
    long long ans=0;
    while(getline(cin,x))
    {
        ans++;
        mp[x]++;
    }
    map<string,int >::iterator it=mp.begin();
    while(it!=mp.end())
    {
        printf("%s ",it->first.c_str());
        printf("%.4f\n",it->second*100.0/ans);
        ++it;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值