poj 1019 Number Sequence

题目链接:点击打开链接

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
#include <iostream>
#define MAX 31269
#include<cmath>
using namespace std;
int a[MAX];
long long  b[MAX];
int main()
{
    a[1]=1;
    b[1]=1;
    for(int i=2; i<MAX; i++ )
    {
        a[i]=a[i-1]+ (int )log10((double)i)+1;
        b[i]=b[i-1]+a[i];
        //log10(i)+1 表示第i组数字列的长度 比 第i-1组 长的位数
        //前i组的长度s[i] 等于 前i-1组的长度s[i-1] + 第i组的长度a[i]
    }    //log()是重载函数,必须对int的i强制类型转换,以确定参数类型

    int n;
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int i=1;
        while(b[i]<n)
        {
            i++;
        }
        int pos=n-b[i-1];
        int len=0;
        for(i=1; len<pos; i++)
        {
            len+=(int )log10((double)i)+1;
        }
        cout<<(i-1)/(int )pow((double)10,len-pos)%10<<endl;
        //之所以i-1,是因为前面寻找第i组长度时,i++多执行了一次
        //i=i-1 此时i刚好等于第n位个置上的数 (数是整体,例如123一百二十三,i刚好等于123,但n指向的可能是1,2或3)
        //pos为n指向的数字在第i组中的下标值
        //len为第i组的长度
        //那么len-pos就是第i组中pos位置后多余的数字位数
        //则若要取出pos位上的数字,就要利用(i-1)/pow(10,len-pos)先删除pos后多余的数字
        //再对剩下的数字取模,就可以得到pos
        //例如要取出1234的2,那么多余的位数有2位:34。那么用1234 / 10^2,得到12,再对12取模10,就得到2
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值