poj 2528 Mayor's posters(线段树+离散化)

题目链接:点击打开链接

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
题目大意:在墙上贴海报,墙的长度很长10000000,总共有n=10000张海报,贴的时候可能会覆盖掉一些,问有多少张海报能露出来,

ps;区间更新与查询统计的问题,当然是是线段树(最近做的就是关于线段树的专题),可是写完之后就超时了,用线段树优化都超时,百思不得其解,后来看了一下大神的博客,说是要离散化,简单的举例了一下离散化的例子,才有所了解离散化,然后就自己写映射map来离散,可是还是超时,在改成大神离散的方法后就过了,可能是STL的速度慢吧,暂时只能这么理解了,一算法都没问题的(超时的离散化在代码中有,能看出原因的还希望留言~)

<span style="font-size:18px;">#include <iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
#include<map>

using namespace std;

struct node
{
    int l,r;
    struct node *left,*right;
    int ant;
}*cur;
struct kode
{
    int point ;
    int num;
} s[20005];
int n;
int num=0;
bool vis[10005];

bool cmp(kode x,kode y)
{
    return x.point < y.point;
}
void updata(node *cur)
{
    cur->left->ant=cur->right->ant=cur->ant;
    cur->ant=0;
}
void build(node *cur,int l,int r)
{
    cur->l=l;
    cur->r=r;
    cur->ant=0;
    if(l<r)
    {
        cur->left=new node;
        cur->right=new node;
        build(cur->left,l,(l+r)/2);
        build(cur->right,(l+r)/2+1,r);
    }
    else cur->left=cur->right=NULL;
    return ;
}

void change(node *cur,int l,int r,int ant)
{
    if(l<=cur->l&&cur->r<=r)
    {
        cur->ant=ant;
    }
    else
    {
        if(cur->ant!=0)
        {
            updata(cur);
        }
        if(l<=(cur->l+cur->r)/2)
            change(cur->left,l,r,ant);
        if(r>(cur->l+cur->r)/2)
            change(cur->right,l,r,ant);
    }
}
void query(node *cur)
{
    if(cur->ant!=0)
    {
        if(!vis[cur->ant])
        {
            num++;
            vis[cur->ant]=1;
        }
        return ;
    }

    query(cur->left);
    query(cur->right);
    return ;
}

int main()
{
    int t;
    scanf("%d",&t);
    int mp[20005][2];

    while(t--)
    {
        scanf("%d",&n);
        ///一开始用map函数写的映射来离散化,总是超时
        /*
        map<int ,int >mp;
        h=0;
        mp.clear();
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a[i],&b[i]);
            s[h++]=a[i];
            s[h++]=b[i];
        }
        sort(s,s+h);
        int k=1;
        for(int i=0; i<h; i++)
        {
            if(mp[s[i]]==0)
                mp[s[i]]=k++;
        }
        for(int i=0; i<n; i++)
        {
            a[i]=mp[a[i]];
            b[i]=mp[b[i]];
        }*/
        for(int i = 0; i<n; i++)//离散化
        {
            scanf("%d%d",&mp[i][0],&mp[i][1]);
            s[2*i].point = mp[i][0];
            s[2*i+1].point = mp[i][1];
            s[2*i].num = -(i+1);
            s[2*i+1].num = i+1;
        }
        sort(s,s+2*n,cmp);
        int tmp = s[0].point,cnt = 1;
        for(int i = 0; i<2*n; i++)
        {
            if(tmp != s[i].point)//如果和前面的不同,这迭代加1
            {
                cnt++;
                tmp = s[i].point;
            }
            if(s[i].num<0)
                mp[-s[i].num-1][0] = cnt;
            else
                mp[s[i].num-1][1] = cnt;
        }
        cur=new node;
        build(cur,1,cnt);
        int top=1;
        for(int i=0; i<n; i++)
        {
            change(cur,mp[i][0],mp[i][1],top++);
        }
        memset(vis,0,sizeof(vis));
        num=0;
        query(cur);
        printf("%d\n",num);
    }
    return 0;
}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值