poj 3694 Network 求割边+LAC优化(Tarjan算法)

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2

0

题目大意:给出图得到结构边,q次询问,每次询问的时候添加一条边后在计算割边的数量

暴力求割边会超时,用LCA算法优化大大降低时间复杂度

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<cmath>
#define M 101000
using namespace std;

int head[M];

struct node
{
    int v;
    int next;
}eage[500000];
int dfn[M],low[M],vis[M];
int fa[M],br[M];
int top;
int n,m,q;
int cnt;
int ans;
void add(int x,int y)
{
    eage[cnt].v=y;
    eage[cnt].next=head[x];
    head[x]=cnt++;
}

void tarjan(int x)
{
    vis[x]=1;
    dfn[x]=low[x]=top++;
    for(int i=head[x];i!=-1;i=eage[i].next)
    {
        int y=eage[i].v;
        if(vis[y]==0)
        {
            fa[y]=x;
            tarjan(y);
            low[x]=min(low[x],low[y]);
            if(low[y]>dfn[x])
            {
                ans++;
                br[y]=1;///割边
            }
        }
        else if(y!=fa[x])low[x]=min(low[x],dfn[y]);
    }
}

void LCA(int u,int v)
{
    while(dfn[u]>dfn[v])//如果v点的深度比u小,说明v是u的low[]值变小了,就肯定不是割边了
    {
        if(br[u])
        {
            ans--;
            br[u]=0;
        }
        u=fa[u];
    }
    while(dfn[v]>dfn[u])
    {
        if(br[v])
        {
            ans--;
            br[v]=0;
        }
        v=fa[v];
    }
    while(u!=v)
    {
        if(br[u])
        {
            ans--;
            br[u]=0;
        }
        u=fa[u];
        if(br[v])
        {
            ans--;
            br[v]=0;
        }
        v=fa[v];
    }

}
int main()
{
    int w=1;
    while(scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        int x,y;
        cnt=0;
        for(int i=0;i<=n;i++)head[i]=-1;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            add(y,x);
        }
        memset(vis,0,sizeof(vis));
        memset(br,0,sizeof(br));
        top=1;
        ans=0;
        for(int i=1;i<=n;i++)
            if(!dfn[i])
        tarjan(i);
        scanf("%d",&q);
        printf("Case %d:\n",w++);
        for(int i=0;i<q;i++)
        {
            scanf("%d%d",&x,&y);
            if(low[x]==low[y])
            {
                printf("%d\n",ans);
                continue;
            }
            LCA(x,y);
            printf("%d\n",ans);
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值