2017sdut省赛选拔(1)--poj1284(原根问题+欧拉回路)

http://poj.org/problem?id=1284

Primitive Roots
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4271 Accepted: 2503

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24
题意比较简单。问题是通过这个题意转到原根问题上来。如果了解过原根的一些定义定理的话也不难联想。关于一些原根的问题建议去一些百科或博客看一下。当读一遍后套上定理这个题就成了。我是用的欧拉函数来求解的,根据定理预处理一下,然后直接套就行了。关于欧拉函数是什么区百度。


///求原根的个数
#include <iostream>
#include <cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int pri[71000];
int a[71000];
int vis[71000];
void phi()
{
    memset(vis,0,sizeof(vis));
    for(int i=2; i<=sqrt(70000+0.5); i++)
    {
        if(!vis[i])
        {
            for(int j=i*i; j<=70000; j+=i)vis[j]=1;
        }
    }
    int top=0;
    for(int i=2; i<=70000; i++)
    {
        if(!vis[i]){pri[top++]=i;}
    }
    for(int j=2; j<=65536; j++)
    {
        long long num=1;
        int x=j;
        int sum=x;
        for(int i=0; i<top&&pri[i]<=x; i++)
        {
            if(x%pri[i]==0)
            {
                sum=sum*(pri[i]-1);
                num=num*pri[i];
                while(x%pri[i]==0)
                {
                    x=x/pri[i];
                }
            }
        }
        a[j]=sum/num;
        //cout<<a[j]<<endl;
    }
}
int main()
{
    phi();///求欧拉函数
    int p;
    while(~scanf("%d",&p))
    {
        printf("%d\n",a[a[p]]);///因为是奇素数,所以输出a[p-1]也行
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值