HDU-1005- Number Sequence (矩阵快速幂)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 176250    Accepted Submission(s): 43589


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunba  

题目很短这里不解释了

题解:

最近才开始学习矩阵快速幂的知识,第一次写矩阵快速幂的题。总体感觉就是递推公式的推导和创建矩阵比较难一点,数学功底得很好才行。

关于矩阵快速幂的知识网上有很多,最好看一些有画图解析的,还是比较好理解的。这个题就是一个裸地求斐波那契的题。

对于F[n]=A*F[n-1]+B*F[n-1]

(由于这些符号不好弄就粘贴的别人的了)

我们可以构造矩阵 
(f[3]f[2])=(a b1 0)(f[2]f[1])   f[3]=a+b  
上式右边两个矩阵相乘是等于左边矩阵的。

不断递推会发现 
(f[4]f[3])=(a2+b aba b)(f[2]f[1])   f[4]=a2+b+ab  
· 
· 
· 
(f[n]f[n1])=(a b1 0)n2(f[2]f[1])

A=(a b1 0)n2  

倒到这就对A求解就行了。和对整数求快速幂是一个道理的。这里不再赘述。

#include <iostream>
#include <bits/stdc++.h>

using namespace std;
typedef long long LL;
int MOD=7;

struct Matrix
{
    int a[2][2];//矩阵大小根据需求修改
    Matrix()
    {
        memset(a,0,sizeof(a));
    }
    void init()
    {
        for(int i=0; i<2; i++)
            for(int j=0; j<2; j++)
                a[i][j]=(i==j);
    }
    Matrix operator * (const Matrix &B)const
    {
        Matrix C;
        for(int i=0; i<2; i++)
            for(int k=0; k<2; k++)
                for(int j=0; j<2; j++)
                    C.a[i][j]=(C.a[i][j]+a[i][k]*B.a[k][j])%MOD;
        return C;
    }
    Matrix operator ^ (const int &t)const
    {
        Matrix A=(*this),res;
        res.init();
        int p=t;
        while(p)
        {
            if(p&1)res=res*A;
            A=A*A;
            p>>=1;
        }
        return res;
    }
} base,ans;

int main()
{
    int A,B,n;
    while(~scanf("%d%d%d",&A,&B,&n))
    {
        if(!A&&!B&&!n)break;
        A=A%MOD;
        B=B%MOD;
        if(n<3)
        {
            cout<<1<<endl;
            continue;
        }
        base.a[0][0]=A;
        base.a[0][1]=B;
        base.a[1][0]=1;
        base.a[1][1]=0;

        ans=base^(n-2);
        cout<<(ans.a[0][0]+ans.a[0][1])%MOD<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值