LightOj 1341 Aladdin and the Flying Carpet (素数筛+求一个数的约数个数)

传送门:http://lightoj.com/volume_showproblem.php?problem=1341


It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where adenotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2


题目大意:

给出两个个数a和b,求有多少对{(h,w)| h>=b&&w>=b }使得h*w=a。这个题如果不失一般性的话暴力和其他的办法所消耗的最大时间是一样的,都是O(T*sqrt(a)),但是就是卡数据。

题解:

先预处理求1e6以内的所有素数,然后求a的约数个数Num=(a=p1^a1 * p2^a2 * p3^a3 * ......)=(a1+1)*(a2+1)*(a3+1)*..........,因为(w,h)和(h,w)算一对,所以num/2;然后在枚举小于b的减去(其实如果正常的话在枚举<b的时候的复杂度也是1e6)。

///http://lightoj.com/volume_showproblem.php?problem=1341
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>

using namespace std;
typedef long long LL;
const int MAXN=1e6+7;
int top,vis[MAXN+100],pri[MAXN+100];
void getprime()
{
    top=0;
    memset(vis,0,sizeof(vis));
    for(int i=2; i<=sqrt(MAXN+0.5); i++)
    {
        if(!vis[i])
        {
            for(int j=i*i; j<=MAXN; j+=i)
                vis[j]=1;
        }
    }
    for(int i=2; i<=MAXN; i++)
    {
        if(!vis[i])pri[++top]=i;
    }
}
int main()
{
    getprime();
    int T,w=0;
    LL a,b;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld",&a,&b);
        if(a<b*b)
        {
            printf("Case %d: 0\n",++w);
            continue;
        }
        LL num=1,temp=a;
        for(int i=1; i<=top&&pri[i]<=sqrt(temp); i++)
        {
            if(temp%pri[i]==0)
            {
                int k=0;
                while(temp%pri[i]==0)temp/=pri[i],k++;
                num=num*(k+1);
            }
        }
        if(temp>1)num=num*2;
        num=num/2;
        for(int i=1; i<b; i++)if(a%i==0)num--;
        printf("Case %d: %lld\n",++w,num);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值