poj 1195 Mobile phones

题目链接:点击打开链接

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4
题目大意:在一个二维的矩形内,每个点表示该处的手机数量,初始化为0。有修改和查询两种操作,修改是该点的值,查询是查两个点之间的矩形内的手机数量


ps:这个题一开始做的挺快的,读题太粗滤,导致wa3次,直接就对两个点之间的差进行相减求和了,起始不然。

这是一个二维的树状数组,当然了也可以是二维的线段树做,但我现在还不会二维线段树,毕竟二维树状数组写起来简单,蛋真正的理解深刻了真的挺难得,现在的我只是在回用的阶段,多少的能明白他的意思。。。


#include <iostream>
#include<cstdio>
#include<cstring>

using namespace std;

long long c[1500][1500];
int n;

int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int y,int val)
{
    while(x<=n)
    {
        int y1=y;
        while(y1<=n)
        {
            c[x][y1]=c[x][y1]+val;
            y1+=lowbit(y1);
        }
        x+=lowbit(x);
    }
}

long long Sum(int x,int y)
{
    int sum=0;
    while(x>0)
    {
        int y1=y;
        while(y1>0)
        {
            sum+=c[x][y1];
            y1-=lowbit(y1);
        }
        x-=lowbit(x);
    }
    return sum;
}
int main()
{

    int id;
    int x,y,a;
    int l,b,r,t;
    memset(c,0,sizeof(c));
    while(scanf("%d",&id))
    {
        if(id==0)
        {
            scanf("%d",&n);
            memset(c,0,sizeof(c));
        }
        else if(id==3)break;
        else if(id==1)
        {
            scanf("%d%d%d",&x,&y,&a);
            add(x+1,y+1,a);
        }
        else if(id==2)
        {
            scanf("%d%d%d%d",&l,&b,&r,&t);
            printf("%lld\n",Sum(r+1,t+1)+Sum(l,b)-Sum(r+1,b)-Sum(l,t+1));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值