试编程判断输入一组正整数:判断输入的数是否既是5又是7的整倍数。若是,则输出yes,否则输出no。输入负数则停止判断。
输入格式:
一行输入一个正整数 直到输入负数为止。
输出格式:
判断输入的数是否既是5又是7的整倍数。若是,则输出yes,否则输出no,输出判断结果后换行。输入负数则停止判断。
输入样例:
在这里给出一组输入。例如:
23
35
67
70
134
-2
输出样例:
在这里给出相应的输出。例如:
no
yes
no
yes
no
package com.ty.java;
import java.util.Scanner;
public class word {
public static void main(String[] args) {
boolean i = true; //作为while循环的条件
while (i == true) {
System.out.println("请输入一个整数:");
Scanner s = new Scanner(System.in);
int a = s.nextInt();
if (a < 0){
break;
}
if (a == 0) {
System.out.println("no");
}
if (a % 5 == 0 && a % 7 == 0) {
System.out.println("yes");
} else {
System.out.println("no");
}
}
}
}
代码运行如下:
com.ty.java.word
请输入一个整数:
23
no
请输入一个整数:
35
yes
请输入一个整数:
67
no
请输入一个整数:
70
yes
请输入一个整数:
134
no
请输入一个整数:
-2
Process finished with exit code 0