A Bug's Life 并查集

题意:给你机组测试数据,每一组前面有一行,有几个虫子, 虫子交配次数。接下来是每一行交配。给虫子做标记比如奇数为公偶数就为母。判断如果两种虫子性别相同,且有性行为就是同性恋。

核心思想:两个虫子到根结点步数奇偶性不同,相同就是同性,这里设置1为同性恋,0否;


Description

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

23 31 22 31 34 21 23 4

Sample Output

Scenario #1:Suspicious bugs found!Scenario #2:No suspicious bugs found!

Hint

Huge input,scanf is recommended.



#include <iostream>

#include <cstdio>

using namespace std;


int par[2020],relation[2020];

bool flag;

void init(int n)

{

    for(int i = 1; i <= n; i++)

    {

        par[i] = i;

        relation[i] = 0;

    }

}

int find(int x)

{

    if(par[x] == x)

        return x;

    int temp = par[x];

    par[x] = find(par[x]);

    relation[x] = (relation[x] + relation[temp] + 2)%2;//儿子到父亲 + 父亲到爷爷 = 儿子到爷爷

    return par[x];

}

bool Union(int a,int b)

{

    int root1 = find(a);

    int root2 = find(b);

    if(root1 == root2)

    {

        if(relation[a] == relation[b])

            flag = true;


    }

    else

    {

        par[root1] = root2;

        relation[root1] = (relation[b] - relation[a]+1 + 2)%2;//更新节点 新节点必须和连接的这个节点 差1 保证不是同性恋

    }

    return flag;

}

int main()

{

    int number,n,m,bug1,bug2;

    scanf("%d",&number);

    for(int i = 1; i <=number; i++ )

    {

        scanf("%d%d",&n,&m);

        flag = false;

        init(n);

        for(int j = 1; j <= m; j++)

        {

            scanf("%d%d",&bug1,&bug2);

            if(flag)

                continue;

            flag = Union(bug1,bug2);

        }

        if(flag)

            printf("Scenario #%d:\nSuspicious bugs found!\n",i);

        else

            printf("Scenario #%d:\nNo suspicious bugs found!\n",i);

        printf("\n");

    }

    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值