HDU3847——Trash Removal(凸包,枚举)

Trash Removal

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 848    Accepted Submission(s): 272
Special Judge


Problem Description
Allied Chute Manufacturers is a company that builds trash chutes. A trash chute is a hollow tube installed in buildings so that trash dropped in at the top will fall down and be collected in the basement. Designing trash chutes is actually highly nontrivial. Depending on what kind of trash people are expected to drop into them, the trash chute needs to have an appropriate size. And since the cost of manufacturing a trash chute is proportional to its size, the company always would like to build a chute that is as small as possible. Choosing the right size can be tough though.

We will consider a 2-dimensional simplification of the chute design problem. A trash chute points straight down and has a constant width. Objects that will be dropped into the trash chute are modeled as polygons. Before an object is dropped into the chute it can be rotated so as to provide an optimal fit. Once dropped, it will travel on a straight path downwards and will not rotate in flight. The following figure shows how an object is first rotated so it fits into the trash chute.

Your task is to compute the smallest chute width that will allow a given polygon to pass through.
 

Input
The input contains several test cases. Each test case starts with a line containing an integer n (3 <= n <= 100), the number of points in the polygon that models the trash item.

The next n lines then contain pairs of integers xi and yi (0 <= x i, y i <= 10^4), giving the coordinates of the polygon vertices in order. All points in one test case are guaranteed to be mutually distinct and the polygon sides will never intersect. (Technically, there is one inevitable exception of two neighboring sides sharing their common vertex. Of course, this is not considered an intersection.)

The last test case is followed by a line containing a single zero.
 

Output
For each test case, display its case number followed by the width of the smallest trash chute through which it can be dropped. Display the minimum width with exactly two digits to the right of the decimal point, rounding up to the nearest multiple of 1/100. Answers within 1/100 of the correct rounded answer will be accepted.
 

Sample Input
  
  
3 0 0 3 0 0 4 4 0 10 10 0 20 10 10 20 0
 

Sample Output
  
  
Case 1: 2.40 Case 2: 14.15
 

Source

题意:给你一个多边形,求能够使该多边形通过的最小宽度。

分析:求凸包,枚举每条边为底的高度,取最小值。 因为是实际应用题,要求结果精确到小数点后两位,所以还要*100向上取整后 /100。

#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <iostream>
#define INF 0x7fffffff
using namespace std;

typedef long long LL;
const int N = 1000 + 10;
const double PI = acos(-1.0);
const double esp = 1e-10;

int dcmp(double x) {if(fabs(x) < esp) return 0; else return x<0?-1:1;}

struct Point
{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y){ }
};

typedef Point Vector;

Vector operator + (Vector A, Vector B) {return Vector(A.x+B.x, A.y+B.y);}
Vector operator - (Vector A, Vector B) {return Vector(A.x-B.x, A.y-B.y);}
Vector operator * (Vector A, double p) {return Vector(A.x*p, A.y*p);}
Vector operator / (Vector A, double p) {return Vector(A.x/p, A.y/p);}
bool operator < (const Point& a, const Point& b){ return a.x<b.x || (a.x==b.x && a.y<b.y);}
bool operator == (const Point& a, const Point& b){return dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)==0;}

double Dot(Vector A, Vector B){ return A.x*B.x+A.y*B.y; }
double Length(Vector A){return sqrt(Dot(A, A));}
double Angle(Vector A, Vector B) {return acos( Dot(A, B)/Length(A)/Length(B) );}

double Cross(Vector A, Vector B) { return A.x*B.y - A.y*B.x ;}
double Area2(Point A, Point B, Point C){return Cross(B-A, C-A); }

double DistanceToLine(Point P, Point A, Point B)
{
    Vector v1 = B-A, v2 = P-A;
    return fabs(Cross(v1, v2)) / Length(v1);
}
int ConvexHull(Point *p, int n, Point *ch)
{
    sort(p,p+n);
    int m = 0;
    for(int i=0;i<n;i++)
    {
        while(m>1 && Cross(ch[m-1]-ch[m-2], p[i]-ch[m-2]) <= 0) m--;
        ch[m++] = p[i];
    }
    int k = m;
    for(int i = n-2 ;i>=0;i--)
    {
        while(m>k && Cross(ch[m-1]-ch[m-2], p[i]-ch[m-2]) <= 0) m--;
        ch[m++] = p[i];
    }
    if(n > 1) m--;
    return m;
}

int n;
Point P[N],ch[N];

int main()
{
    int C=1;
    while(scanf("%d",&n)!=EOF && n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&P[i].x,&P[i].y);
        }
        int m=ConvexHull(P,n,ch);
        double ans = 1e20;
        for(int i=1;i<=m;i++)
        {
            double max_dis = 0;
            for(int j=0;j<m;j++)
            {
                max_dis = max(max_dis, DistanceToLine(ch[j],ch[i%m],ch[i-1]));
            }
            ans = min(ans, max_dis);
        }
        ans = ceil(ans * 100) / 100.0;

        printf("Case %d: %.2lf\n",C++, ans);
    }

    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值