The order of a Tree HDU

                                                 The order of  a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 834    Accepted Submission(s): 452


Problem Description
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find  the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
 

Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.
 

Output
One line with n intergers, which are the order of a tree that generate the same tree with the least  lexicographic.
 

Sample Input
  
  
4 1 3 4 2
 

Sample Output
  
  
1 3 2 4
 
  普通的二叉树插入过程。
#include <stdio.h>
#include <stdlib.h>

bool first;
typedef struct BITree
{
    int data;
    BITree *Left,*Right;
}BiTree,*Tree;

BiTree *Insert(Tree root,int num)
{
    if(root == NULL){
        root = (Tree)malloc(sizeof(BITree));
        root->data = num;
        root->Left = NULL;
        root->Right = NULL;

    }else
    {
        if(num < root->data)
          root->Left = Insert(root->Left,num);
        else
          root->Right = Insert(root->Right,num);
    }
    return root;
}

void Print(Tree root)
{
    if(first)
      printf("%d",root->data);
    else
      printf(" %d",root->data);
    first = false;
    if(root->Left != NULL)
      Print(root->Left);
    if(root->Right != NULL)
      Print(root->Right);
}
int main()
{
    int n,i,t;
    Tree root;
    while(~scanf("%d",&n))
    {
        root = NULL;
        for(i = 1;i <= n;i++)
        {
            scanf("%d",&t);
            root = Insert(root,t);
        }
        first = true;
        Print(root);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值