HDU 3999 The order of a Tree

今天回学校了,准确的说是昨天回来的,今天第一天来机房,暑假搞的东西欠下的债不少,然后补补题 发现是个大水题

The order of a Tree
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4235 Accepted Submission(s): 2151
Problem Description
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:

  1. insert a key k to a empty tree, then the tree become a tree with
    only one node;
  2. insert a key k to a nonempty tree, if k is less than the root ,insert
    it to the left sub-tree;else insert k to the right sub-tree.
    We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.
    Input
    There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.

Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.

Sample Input
4
1 3 4 2
Sample Output
1 3 2 4

Source
2011 Multi-University Training Contest 16 - Host by TJU

Recommend
lcy | We have carefully selected several similar problems for you: 4000 1710 3627 3998 3996

二叉平衡树 直接输出先序遍历,指针写法记得清理内存

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
struct Node {
    Node *l,*r;
    int data;
}*root = NULL;

void Insert(Node *&cur,int x) {
    if(cur == NULL) {
        cur = new Node;
        cur -> data = x;
        cur -> r = cur -> l = NULL;
    }
    else {
        if(x < cur -> data) Insert(cur -> l ,x);
        else Insert(cur -> r,x);
        return ;
    }
}
void Print(Node* p,bool flag) {
    if(flag) printf(" ");

    printf("%d",p -> data);
    if(p -> l != NULL) Print(p -> l,1);
    if(p -> r != NULL) Print(p -> r,1);
}

void Remove(Node* cur) {// 多组数据释放内存
    if(cur == NULL) return ;
    Remove(cur ->r);
    Remove(cur ->l);
    delete cur;
}

int main(int argc,char* argv[]) {
    int n;
    while(scanf("%d",&n) == 1){
        root = NULL;
        for(int x,i=1; i<=n; i++)  {
            scanf("%d",&x);
            Insert(root,x);
        }
        Print(root,0);
        printf("\n");
        Remove(root);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值