九度oj 题目1005:Graduate Admission 【ZJU2011考研机试题4】

题目1005:Graduate Admission

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3937

解决:1111

题目描述:

    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

    Each input file may contain more than one test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
样例输出:
0 10
3
5 6 7
2 8

1 4
来源:
2011年浙江大学计算机及软件工程研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7729-1-1.html


这类题目千万别怕,看似很复杂,弄清逻辑,几个for循环搞定

对学生进行排名,按成绩从高到低依次来安排学校, 把排名

存在学生结构体里(注意排名可重复,如:1 2 2 2 5 6 7 7 9)。

学校录取的结果存在学校结构体 ,用 小根堆 来存。


#include <stdio.h>
#include<queue>
#include<algorithm>
using namespace std;
struct student{
	int id;   //学生编号
	int ge;  //GE分数
	int gi;	 //GI分数
	double ave;
	int school[6]; //申请的学校
	int rank; //最终排名
}stu[40010];
struct school{
	int id;  //学校编号
	int quota;  //招生的名额数
	int lRank; //最后一名的排名,相当于最低分数线。
	priority_queue<int,vector<int>,greater<int> > stuId;
}sch[110];
bool cmp(student a,student b) //对学生进行排序。
{
	if(a.ave!=b.ave)
		return a.ave>b.ave;
	else
		return a.ge>b.ge;
}
int main()
{
    int n,m,k,i,j;
    //freopen("G:\\in.txt","r",stdin);
//-------------------进行输入----------------------
    while(scanf("%d%d%d",&n,&m,&k)!=EOF){
		for(i=0;i<m;i++)
			scanf("%d",&sch[i].quota);
		for(i=0;i<n;i++){
			stu[i].id=i;
			scanf("%d%d",&stu[i].ge,&stu[i].gi);
			stu[i].ave=(double)(stu[i].ge+stu[i].gi)/2;
			for(j=0;j<k;j++)
				scanf("%d",&stu[i].school[j]);
		}
//-------------------处理输入----------------------
		sort(stu,stu+n,cmp);
		for(i=0;i<n;i++){   //求出每个学生的排名
			int cnt=1;
			for(j=0;j<n;j++){
				if(stu[j].ave>stu[i].ave)
					cnt++;
				else if(stu[j].ave=stu[i].ave){
					if(stu[j].ge>stu[i].ge)
						cnt++;
					else{	
						stu[i].rank=cnt;
						break;  //找到排名则跳出循环查找
					}
				}
			}
		}
//		for(i=0;i<n;i++)
//			printf("**%d**",stu[i].rank);

		for(i=0;i<n;i++){
			for(j=0;j<k;j++){  //对于每个学生依次查询所感兴趣的学校有没有名额
				if(sch[stu[i].school[j]].quota>0){ //如果学校有名额---------------------------则录取
					sch[stu[i].school[j]].quota--;
					sch[stu[i].school[j]].stuId.push(stu[i].id);
					sch[stu[i].school[j]].lRank=stu[i].rank;
					break;
				}
				if(sch[stu[i].school[j]].quota==0){  //如果没名额且但跟最后一名排名相等-------则录取
					if(sch[stu[i].school[j]].lRank==stu[i].rank){
						sch[stu[i].school[j]].stuId.push(stu[i].id);
						break;
					}
				}
			}
		}
		for(i=0;i<m;i++){
			if(sch[i].stuId.empty())
				printf("\n");
			else{
				printf("%d",sch[i].stuId.top()); //单独输出第一个元素以免前面有空格。
				sch[i].stuId.pop();
				while(!sch[i].stuId.empty()){
					printf(" %d",sch[i].stuId.top());
					sch[i].stuId.pop();
				}
				printf("\n");
			}
		}
    }   
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值