1080 Graduate Admission (30)

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G~E~, and the interview grade G~I~. The final grade of an applicant is (G~E~ + G~I~) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G~E~. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's G~E~ and G~I~, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

思路:

每个考生有两个成绩:GE和GI,最终成绩为(GE + GI) / 2;按照最终成绩排名,如果最终成绩相同,就按照GE排名,如果仍然相同,他们的排名就是相同的。每个申请者有K个选择院校,每个学校也有招生人数限制。按照排名先后,如果当前考生的第一个志愿学校的名额还没满,就录取进去;如果当前志愿名额满了但是该校最后一个录取的人的排名和当前考生相同,则不管招生人数限制,依旧应该被录取;否则考虑该生的下一个志愿。如果所有志愿都没有能被录取,则该生落榜。

C++:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int n, m, k;
struct stu {
    int id, GE, GI, Grade, rank;
    vector<int> vSchool;
};
struct sch {
    int nowNum, maxNum, lastRank;
    vector<int> stuID;
};
bool cmp1(stu a, stu b) {
    return a.Grade != b.Grade ? a.Grade > b.Grade : a.GE > b.GE;
}
int main() {
    scanf("%d%d%d", &n, &m, &k);
    vector<stu> student(n);
    vector<sch> school(m);
    for(int i = 0; i < m; i++) {
        int temp;
        scanf("%d", &temp);
        school[i] = {0, temp, -1};
    }
    for(int i = 0; i < n; i++) {
        student[i].vSchool.resize(k);
        student[i].id = i;
        scanf("%d%d", &student[i].GE, &student[i].GI);
        student[i].Grade = (student[i].GE + student[i].GI) / 2;
        for(int j = 0; j < k; j++) {
            int temp;
            scanf("%d", &temp);
            student[i].vSchool[j] = temp;
        }
    }
    sort(student.begin(), student.end(), cmp1);
    student[0].rank = 1;
    for(int i = 1; i < n; i++) {
        if(student[i].Grade == student[i - 1].Grade && student[i].GE == student[i - 1].GE)
            student[i].rank = student[i-1].rank;
        else
            student[i].rank = i;
    }
    for(int i = 0; i < n; i++) {
        for(int j = 0; j < k; j++) {
            int schoolID = student[i].vSchool[j];
            int myRank = student[i].rank;
            int myID = student[i].id;
            if(school[schoolID].nowNum < school[schoolID].maxNum || school[schoolID].lastRank == myRank) {
                school[schoolID].nowNum++;
                school[schoolID].lastRank = myRank;
                school[schoolID].stuID.push_back(myID);
                break;
            }
        }
    }
    for(int i = 0; i < m; i++) {
        sort(school[i].stuID.begin(), school[i].stuID.end());
        for(int j = 0; j < school[i].stuID.size(); j++) {
            if(j != 0) printf(" ");
            printf("%d", school[i].stuID[j]);
        }
        printf("\n");
    }
    return 0;
}

 

逻辑斯蒂回归(Logistic Regression)是一种常用的分类算法,常用于二分类问题中,如预测研究生能否被录取。Kaggle的Graduate Admission数据集包含了申请人的各项信息,例如GRE分数、TOEFL分数、大学GPA、科研经验、推荐信等,目标变量通常是“是否被录取”(是否被研究生院接受)。 首先,我们来理解数据集属性的意义: 1. GRE Score: 研究生入学考试成绩 2. TOEFL Score: 英语水平测试得分 3. University Rating: 学校排名 4. SOP: Statement of Purpose(个人陈述)的质量 5. LOR: Letter of Recommendation(推荐信)的质量 6. CGPA: 学术平均绩点 7. Research: 科研经历(0或1) 8. Chance of Admit: 录取概率(这个不是原始数据,而是我们最终需要预测的目标) 数据预处理步骤主要包括: 1. **加载数据**:使用pandas库读取csv文件并查看基本信息。 2. **缺失值处理**:检查是否存在缺失值,并选择填充、删除或估算策略。 3. **编码分类变量**:将类别型特征转换成数值型,如使用one-hot encoding或者LabelEncoder。 4. **标准化或归一化**:对于数值型特征,通常会做数据缩放,如Z-score标准化或min-max归一化。 5. **划分训练集和测试集**:通常采用80%的数据作为训练集,剩余的20%作为测试集。 6. **特征工程**:如果有必要,可以创建新的特征或调整现有特征。 逻辑斯蒂回归的预测原理是基于sigmoid函数,该函数将线性组合后的输入映射到0到1之间,表示事件发生的可能性。模型学习如何调整权重系数,使得给定输入条件下,正类(如录取)的概率最大化。 实现过程(Python示例,假设使用sklearn库): ```python import pandas as pd from sklearn.model_selection import train_test_split from sklearn.preprocessing import StandardScaler from sklearn.linear_model import LogisticRegression from sklearn.metrics import accuracy_score # 1. 加载数据 data = pd.read_csv('Admission_Predict.csv') # 2. 数据预处理 # ... 缺失值处理、编码、标准化等操作 # 3. 划分特征和目标 X = data.drop('Chance of Admit', axis=1) y = data['Chance of Admit'] # 4. 划分训练集和测试集 X_train, X_test, y_train, y_test = train_test_split(X, y, test_size=0.2, random_state=42) # 5. 特征缩放 scaler = StandardScaler() X_train_scaled = scaler.fit_transform(X_train) X_test_scaled = scaler.transform(X_test) # 6. 创建模型并拟合 model = LogisticRegression() model.fit(X_train_scaled, y_train) # 7. 预测 y_pred = model.predict(X_test_scaled) # 8. 评估模型性能 accuracy = accuracy_score(y_test, y_pred) print(f"Accuracy: {accuracy}") ```
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值