POJ 1426 Find The Multiple

链接:http://poj.org/problem?id=1426

题目:

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16771 Accepted: 6835 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111


解题思路:

题目的要求是让你找出一个只由0和1组成的10进制数m,m满足是n的倍数。既然m只由0和1组成,m的最高位必然是1,后面每一位不是0就是1,我们可以对m进行bfs()搜索,每一层的结果都是在上层的基础上*10或是*10+1。当m满足是n的倍数时,就终止搜索。注意:要用G++编译器提交,否则会ME;


代码 :

#include <iostream>
#include <queue>
#include <cstdio>
using namespace std;

queue<long long> q;
int n;

long long bfs()
{
	while(!q.empty()) q.pop();
	q.push(1);
	
	while(!q.empty())
	{
		long long x = q.front();
		q.pop();
		if(0 == x % n) return x;
		q.push(10 * x);
		q.push(10 * x + 1);
	}
	
	return 0;
}

int main()
{
	while(~scanf("%d", &n) && n)
	{
		printf("%I64d\n", bfs());
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值