2010 Asia Fuzhou Regional Contest POJ 3697 Selecting courses

题目:

Selecting courses

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others)
Total Submission(s): 1650    Accepted Submission(s): 406


Problem Description
    A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (A i,B i). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course

You are to find the maximum number of courses that a student can select.

 

Input
There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=A i<B i<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

 

Output
For each test case output a line containing an integer indicating the maximum number of courses that a student can select.
 

Sample Input
  
  
2 1 10 4 5 0
 

Sample Output
  
  
2
 

题意:

学生选课,给出每门课可选的时间段,每门课只能被选一次,同一个时间只能选一门课,每隔5分钟可以选一次课,求最多可以选几门课。

解题思路:

贪心,我们可以枚举选课的起始时间t0,以t0(t0 = 0,1,2,3,4因为是每隔5分钟选一次课)为起点,枚举之后所有可选的时间再把所有课程的时段遍历一下,找出可选的并且结束时间最早的那门课,选上,并标记,找出所有以t0为点的最大值,即为最多可选的课。

代码:


#include <cstdio>
#include <cstring>

const int MAXN = 310;
struct P
{
    int x, y;
};
P p[MAXN];
int vis[MAXN];

int main()
{
    int n;
    while(~scanf("%d", &n) && n)
    {
        int ret;
        memset(p, 0, sizeof(p));
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &p[i].x, &p[i].y);
        }

        int ans = -1;
        for(int m = 0; m < 5; m++)
        {
            memset(vis, 0, sizeof(vis));
            ret = 0;
            for(int i = m; i <= 1000; i += 5)
            {
                int x = -1;
                for(int j = 0; j < n; j++)
                {
                    if(!vis[j] && i >= p[j].x && i < p[j].y)
                    {
                        if(-1 == x || p[j].y < p[x].y)
                        {
                            x = j;
                        }
                    }
                }
                if(-1 != x)
                {
                    ret++;
                    vis[x] = 1;
                }
            }
            if(ret > ans) ans = ret;
        }
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值