HDOJ 4927 Series 1

博客探讨了HDOJ 4927题目,涉及序列的求解方法。通过观察序列模式,发现与杨辉三角的系数相关,并推导出通项公式:(-1)^(n-1-i)*C(n-1,i)*a[i]。为避免超时,使用递推公式计算组合数,并推荐使用Java处理大数问题。" 116299495,9838180,压缩感知:MP与OMP算法详解及Matlab实现,"['信号处理', '压缩感知', '算法', 'Matlab编程']
摘要由CSDN通过智能技术生成

题目:

Series 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 132    Accepted Submission(s): 34


Problem Description
Let A be an integral series {A 1, A 2, . . . , A n}.

The zero-order series of A is A itself.

The first-order series of A is {B 1, B 2, . . . , B n-1},where B i  = A i+1  - A i.

The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).

Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 

Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).

For each test case:
The first line contains a single integer n(1<=n<=3000), which denotes the length of series A.
The second line consists of n integers, describing A 1, A 2, . . . , A n. (0<=A i<=10 5)
 

Output
For each test case, output the required integer in a line.
 

Sample Input
  
  
2 3 1 2 3 4 1 5 7 2
 

Sample Output
  
  
0 -5
 

传送门:点击打开链接

解题思路:

n = 1时,答案为a[0];

n = 2时,答案为a[1] - a[0];

n = 3时,答案为a[2] - 2*a[1] + a[0];

n = 4时,答案为a[3] - 3*a[2] + 3*a[1] - a[0];

n = 5时,答案为a[4] - 4*a[3] + 6*a[2] - 4*a[1] + a[0];

我们会发现,系数其实就是杨辉三角形,

我们可以推出通项公式:(-1)^(n-1-i)*C(n-1,i)a[i]

优化,如果每一项都求组合数,会超时,我们可以这么做,利用递推公式:C(n,i) = C(n, i-1) * (n-i+1) / i,求出每一个组合数;

ps:这题中间的数据会比较大,需要用大数,所以,我们选择java。


代码:

import java.io.BufferedInputStream;
import java.math.*;
import java.util.Scanner;
 
public class Main{
    public static BigInteger cnk(int n, int k){
        BigInteger fenzi = new BigInteger("1");
        BigInteger fenmu = new BigInteger("1");
        for(int i=n-k+1; i <= n; i++){
            String s = Integer.toString(i);
            BigInteger stobig = new BigInteger(s);
            fenzi = fenzi.multiply(stobig);
    }
    for(int j=1; j <= k; j++){
        String ss = Integer.toString(j);
        BigInteger stobig2 = new BigInteger(ss);
        fenmu = fenmu.multiply(stobig2);
    }
    BigInteger result = fenzi.divide(fenmu);
    return result;
    }
    
    public static void main(String args[]){
        Scanner cin = new Scanner(new BufferedInputStream(System.in));
        int n, t;
        BigInteger a, ans, b, c, d;
        t = cin.nextInt();
        while(0 != t){
            n = cin.nextInt();
            ans = BigInteger.ZERO;
            b = BigInteger.ONE;
            d = BigInteger.ONE;
            c = ans.subtract(b);
            if(0 == n%2) b = c;
            for(int i = 1; i <= n; ++i){
                a = cin.nextBigInteger();
                a = a.multiply(b);
                b = b.multiply(c);
                a = a.multiply(d);
                d = d.multiply(BigInteger.valueOf(n-i)).divide(BigInteger.valueOf(i));
                ans = ans.add(a);
        //        System.out.println(a.toString());
            }
            //BigInteger result = cnk(2, 0);
            //System.out.println(result.toString());
            System.out.println(ans.toString());
            t--;
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值