ACdream区域赛指导赛之手速赛系列(4) C Captain Hammer

题目:


Captain Hammer

Special Judge Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)
Problem Description

The Hamjet is a true marvel of aircraft engineering. It is a jet airplane with a single engine so powerful that it burns all of its fuel instantly during takeoff. The Hamjet doesn't have any wings because who needs them when the fuselage is made of a special Wonderflonium isotope that makes it impervious to harm.

Piloting the Hamjet is a not a job for your typical, meek-bodied superhero. That's why the Hamjet belongs to Captain Hammer, who is himself impervious to harm. The G-forces that the pilot endures when taking a trip in the Hamjet are legen-dary.

The Hamjet takes off at an angle of θ degrees up and a speed of V meters per second. V is a fixed value that is determined by the awesome power of the Hamjet engine and the capacity of its fuel tank. The destination is D meters away. Your job is to program the Hamjet's computer to calculate θ given V and D.

Fortunately, the Hamjet's Wondeflonium hull is impervious to air friction. Even more fortunately, the Hamjet doesn't fly too far or too high, so you can assume that the Earth is flat, and that the acceleration due to gravity is a constant 9.8 m/s^2 down.

Input

The first line of the input gives the number of test cases, T.

T lines follow. Each line will contain two positive integers -- V and D.

1 ≤ T ≤ 4500
1 ≤ V ≤ 300
1 ≤ D ≤ 10000

It is guaranteed that each test case will be solvable.

Output

For each test case, output one line containing "Case #x: θ", where x is the case number (starting from 1) and θ is in degrees up from the the horizontal.

If there are several possible answers, output the smallest positive one.

An answer will be considered correct if it is within 10^-6 of the exact answer, in absolute or relative error.

Sample Input
3
98 980
98 490
299 1234
Sample Output
Case #1: 45.0000000
Case #2: 15.0000000
Case #3: 3.8870928

传送门: 点击打开链接

解题思路:

这是一个抛物线运动,根据中学的物理知识,我们可以推出公式,sin2θ = G*D/(V*V),我们需要求出θ(0<=θ<=π/2),需要用二分求,直接用θ的表达式会出现精度问题。

代码:

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
 
typedef double DB;
const DB PI = 4 * atan(1.0);
const DB G = 9.8;
const DB EPS = 1e-10;
 
int main()
{
    int t, w = 1;
    DB v, d, ans;
   // printf("%.7f\n",90/PI*asin(0.5));
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf%lf", &v, &d);
        DB l = 0, r = PI/2.0, m = G*d/v/v;
        while(r-l >= EPS)
        {
            DB mid = (l + r) / 2.0;
            if(2*mid <= PI/2.0)
            {
                if(sin(2*mid) >= m)
                    r = mid;
                else
                    l = mid;
            }
            else
            {
                if(sin(2*mid) >= m)
                    l = mid;
                else
                    r = mid;
            }
            ans = mid;
        }
        printf("Case #%d: %.7f\n", w++, ans*180/PI);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值